Showing results for 
Search instead for 
Did you mean: 

Cant install Windows to new SSD

Esteemed Contributor III


I just got my first SSD, an Intel 520 Series, and I'm trying to install Windows 7 on it, with no luck so far.

The Windows installer states that "Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure the disk's controller is enabled in the computer's BIOS menu".

My setup:

Intel Core 2 Duo E8500

Asus P5E3 motherboard


WD Caviar HDD, 320GB, SATAII

Intel SSD 520 Series, 120 GB

What I have done so far:

- Updated Asus BIOS to version 1404.

- Unplugged my WD HDD, leaving only the SSD and a DVD drive as SATA devices.

- Used the clean command in diskpart.

- Tried both IDE and AHCI configurations for SATA.

- Confirmed that the SSD can be seen from BIOS.

- Set the boot order to: 1: DVD-drive, 2: SSD

If I configure SATA as AHCI, Windows installer claims that it can't install on the SSD.

I found some Intel drivers, and loading them reveals that "Intel ICH9R/DO/DH SATA AHCI Controller" is compatible with my hardware. It seems to install the driver, but nothing changes after that, and I have tried refreshing the drive list. I have also tried to use the clean command in diskpart, both before and after.

If I configure SATA as IDE, Windows will start installing on the SSD. After it reboots the installation starts all over again from the DVD. Usually I have to press a key to boot from a CD or DVD, but I doesn't ask me and I'm not touching any keys. If I eject the DVD just as it reboots, Windows installation picks up where it should, but remains stuck on "Completing installation". I waited for 3 hours just to be sure, but nothing happens.

I have tried this multiple times.

If I boot to my current Windows installation on the WD HDD I can see the SSD just fine from Explorer. I can also read and write to it.

This was the very first thing I did, before attempting to install Windows on the SSD. The performance seems a little off, it appears to freeze for 30 seconds from time to time when transferring files, but I'm guessing its because I'm running SATA in IDE mode in this scenario?

So, what am I doing wrong? How can I get Windows installed?

Any help would be appreciated. Thanks.


Esteemed Contributor III

I can't help here, but I can confirm that the P5E3 deluxe motherboard also has issues with SSD (Intel 330-series) in that the drive can not be used at all on the board (appears in Bios, but fails for a) installing windows or b) being used as a storage drive (drive connects/disconnects repeatedly in Windows)).