Showing results for 
Search instead for 
Did you mean: 

[HELP] Repeating BSOD Intel 520 180GB

Esteemed Contributor III

Hello everyone in the Intel community. I really need some help in resolving an issue with my Intel SSD as stated in the title above. I purchased my 520 series 180GB drive on 2nd Sept, had Win7 Enterprise 64-bit installed on it by my school's helpdesk. The drive is used in a Lenovo laptop with a SATA3 interface, specs below;

  • Lenovo Y460P
  • Intel 2630QM/2720QM CPU
  • Intel HM65 chipset
  • AMD HD6550M GPU

Where the CPU differs is because my laptop's motherboard was fried and was using the same-model loan laptop from Lenovo during 5th Sept - 10th Sept. I'm now currently on my own laptop again, and still experiencing the same BSOD issue. All device drivers updated as claimed by Device Manager, with my . I ran Window's verifier for 7-hours straight without problems. I didn't ran it for 24 hours because the laptop would run too slow. The last time I ran CHKDSK was on 9th Sept without any problems.

I hope anyone out there is able to come up with a solution to solve this recurring BSOD issue, and that an RMA will only be my final option. All minidump info are from WinDbg. WinDbg seems to indicate that there is an I/O error with the 520 drive. Attached below is a link to all the minidump since the first one. 

BSOD Details:

  • BSOD minidump zip (all 0xF4):
  • BSOD probably caused by: csrss.exe
  • BSOD personal observation: When the BSOD occurs, I would usually be doing something regular like web-browsing or MS Word, when suddenly several running applications get shutdown, the taskbar goes missing, then it seems like windows explorer stops functioning as all programs get "wiped out" leaving just the desktop wallpaper. About 5-15 seconds later, the BSOD would appear.

Here's WinDbg's analysis of the latest BSOD;


* *

* Bugcheck Analysis *

* *


Use !analyze -v to get detailed debugging information.

BugCheck F4, {3, fffffa8006618b30, fffffa8006618e10, fffff8000399d510}

Probably caused by : csrss.exe

Followup: MachineOwner


2: kd> !analyze -v


* *

* Bugcheck Analysis *

* *



A process or thread crucial to system operation has unexpectedly exited or been


Several processes and threads are necessary for the operation of the

system; when they are terminated (for any reason), the system can no

longer function.


Arg1: 0000000000000003, Process

Arg2: fffffa8006618b30, Terminating object

Arg3: fffffa8006618e10, Process image file name

Arg4: fffff8000399d510, Explanatory message (ascii)

Debugging Details:


PROCESS_OBJECT: fffffa8006618b30

IMAGE_NAME: csrss.exe



FAULTING_MODULE: 0000000000000000

PROCESS_NAME: csrss.exe

EXCEPTION_CODE: (NTSTATUS) 0xc0000006 - The instruction at 0x%p referenced memory at 0x%p. The required data was not placed into memory because of an I/O error status of 0x%x.






fffff880`0445ae38 fffff800`03a25892 : 00000000`000000f4 00000000`00000003 fffffa80`06618b30 fffffa80`06618e10 : nt!KeBugCheckEx

fffff880`0445ae40 fffff800`039d1e8b : ffffffff`ffffffff fffffa80`06b52b50 fffffa80`06618b30 fffffa80`06618b30 : nt!PspCatchCriticalBreak+0x92

fffff880`0445ae80 fffff800`03950f74 : ffffffff`ffffffff 00000000`00000001 fffffa80`06618b30 00000000`00000008 : nt! ?? ::NNGAKEGL::`string'+0x176d6

fffff880`0445aed0 fffff800`0369d453 : fffffa80`06618b30 fffff800`c0000006 fffffa80`06b52b50 00000000`00e90c80 : nt!NtTerminateProcess+0xf4

fffff880`0445af50 fffff800`03699a10 : fffff800`036e8e7f fffff880`0445ba38 fffff880`0445b790 fffff880`0445bae0 : nt!KiSystemServiceCopyEnd+0x13

fffff880`0445b0e8 fffff800`036e8e7f : fffff880`0445ba38 fffff880`0445b790 fffff880`0445bae0 000007fe`fd45a06c : nt!KiServiceLinkage

fffff880`0445b0f0 fffff800`0369d842 : fffff880`0445ba38 00000000`00ed0000 fffff880`0445bae0 000007fe`fd45eea4 : nt! ?? ::FNODOBFM::`string'+0x48e34

fffff880`0445b900 fffff800`0369c3ba : 00000000`00000000 000007fe`fd44d828 fffffa80`07a71001 00000000`00ed0000 : nt!KiExceptionDispatch+0xc2

fffff880`0445bae0 00000000`76fe8f55 : 00000000`00000000 00000000`00000000 00000000`000...


Esteemed Contributor III

UPDATE: A little disappointed that no one from Intel replied. Anyhow, I think I may have found the solution. And I found it in Intel's very own community, albeit a different category, URL below;

To quote from that long post,

2) I'm beginning to think these newer Intel SSDs with Marvell controllers are intrinsically temperamental. (That's a nice way of putting it.) Yesterday evening I installed a new 120GB 520 series SSD in an Asus U56E laptop, approximately 6 months old. Fresh installed Win 7, and installed all drivers including Intel chipset driver. The result? NTFS.sys critical object termination BSODs on every wake-up from sleep mode. Switching to the Microsoft driver made no difference, however switching to the separate RST Intel driver fixed the problem immediately. (Just to be sure, I switched it back to the driver provided by the chipset, and it was back to BSODing on wake-up.)

The interesting thing? It was a Series 6 / C200 chipset, which is the same as the server boards. Next time I am on-site, I am going to put one of the servers into sleep mode; it will be interesting to see if it BSODs similarly. That would be great, as it might provide me a way to actually figure out whether or not I have fixed the problem, rather than having to wait a week or more. (That is assuming it follows that no BSOD on wakeup also means no lockups after a week, which is pure speculation. Worth a shot, since I'm in hail mary land now!)

I encountered an exact situation as this poster from the other thread. Installed my 520 180GB SSD in my 1.5 year-old Lenovo Y460P, with a fresh install of Win7. The default Intel Series 6/C200 Chipset was seen as the device driver for the 520 drive in Device Manager.

Although I did not experience BSOD on wake-up from sleep mode, I did experience the same BSOD frequently. I manually downloaded the Intel RST driver, installed it, and I have been running the laptop (with a number of sleep modes) since then without any problems. Task manager currently lists the current up time at 2 days.

Seems that installing Intel's RST driver has stopped the repeating BSODs (listed as "Intel Mobile Express Chipset SATA AHCI Controller" in Device Manager). Fingers crossed.

Hopefully this is the permanent solution to my problem, and anyone facing the same issue. Will mark this as solved if I do not experience any form of hangs, crash or BSOD over the next 2 weeks.



Esteemed Contributor III

Hamizan, this forum is more oriented towards users helping other users, rather than an Intel support medium.

Diagnosing BSOD problems is difficult without having the PC in front of you, so you can check everything easily. Such as, what SATA driver is being used. Also, laptop PCs tend to have more problems with hardware that is added by the owner, since their BIOS is very limited, and tuned for the hardware the manufacture offers as standard or options.

We also don't remember how complex PCs are, and how easy it is to make mistakes. For example, in the text you posted from another thread, there is this statement:

"I'm beginning to think these newer Intel SSDs with Marvell controllers are intrinsically temperamental."

All the 520 SSDs use SandForce controllers. The point is even an IT professional can make mistakes on simple things like this. Another comment on that post is that I have personally had wake from Sleep issues with hardware using one of the Intel Series 6/C200 Chipsets, using SSDs as the OS drive. That was also when I used IRST as the SATA driver. That issue was never resolved by me, but the same SSDs used with Intel 7 series chipset boards, and IRST, wake from Sleep just fine every time. IMO, the issue is probably in the 6 series chipset itself, and not the SSD or the IRST driver.

I have also seen people claim that IRST causes BSODs with SSDs, and using another driver fixed the issue. As they say, the devil is in the details, and there are more details that we are unaware of than we can imagine.