Showing results for 
Search instead for 
Did you mean: 

X25-M, controller timeout

Esteemed Contributor III


I've got an 80Gb X25-M, first generation (50nm one), latest firmware (April 2009, all more recent updates are G2/34nm IIRC). It worked finely as a system for like nine months, but now gives me halfsecond freezes, with the following recorded in the event log: "The device, \Device\Ide\iaStor0, did not respond within the timeout period."

I've got an MSI P55-GD65 motherboard (P55 chipset) and run Windows 7 x64.

The controller is in RAID mode, with X25-M connected to SATA port 0 as a standalone drive (it's a boot/system drive), a pair of 500 GB Samsung SpinPoint F3 in RAID 0, connected to SATA ports 2 and 3, along with a NEC burner (don't think the model is important) connected to SATA port 1.

The problem is that this configuration was running for some time without any problems, so I don't think it's a compatibility or software problem.

The only thing I changed in last month was upgrading Matrix Storage Manager (8.x) to Rapid Storage Technology (9.x), but reverting this change doesn't help.

The easy way to trigger the error is to start writing something large on the drive, the data is not getting corrupted (I wrote a large archive there, then rebooted and checked it's integrity, it's fine), but OS freezes down that even mouse cursor is "jumping" instead of moving smoothly, and the event log is filled with aforementioned timeout messages.

The internal drive performance counters (available via S.M.A.R.T., displayed by Intel SSD Optimizer) show that drive has 95% lifetime remains, with 1.58Tb data written, all attributes are "green".

I did a bit of searching on the internet, and the almost universal recipes are "check your wiring" (did that already, tried replacing with other ones) and "disable RAID" (I need that RAID, don't think that disabling raid would help since it's not a compatibility problem after all).

I already tried formattng/repartitioning the drive (didn't help, and I really doubt it should from how I know SSDs work).

I didn't try ATA secure erase (Intel doesn't have a publicly available utility, HDDErase 3.3 doesn't recognize my controller, HDDErase 4.0 doesn't work with X25-Ms, hdparm-ing from some Linux LiveCD sounds like too much hassle to me as an end-user, since I don't think that would help).

Should I do an ATA secure erase via LiveCD? Try to contact local Intel Customer Service and try to RMA it? Just hammer it to pieces? Any other advice? 😃

Thank you all in advance.



I would like to suggest you a secure erase, you can download a bootable disk from the following site: if possible test the Solid State Drive in a different compatible computer and if the Solid State Drive does not respond at all I recommend you to contact the Solid State Drive support phone number: 916 377 7000 option 6 to have the Solid State Drive replaced.

Esteemed Contributor III

I don't think the SSD is your problem I think its to do with your RAID and that one of your HDD's is failing.

You say you reverted the Matrix Storage Manager from Rapid Storage Technology changes but do try Matrix Storage Manager 8.8 and see if that fixes things and yes it does work for win 7 x64.