Showing results for 
Search instead for 
Did you mean: 

RMA This x25-m 80GB G2?

Esteemed Contributor III

I got a second generation x25-M 80GB about 5 weeks ago. When we first met, it was love @ first install. Then the honeymoon ended and now I think my SSD is beginning to show signs of unhappiness

The symptoms are that I will randomly get corrupt files on my filesystem. Sometimes I can go a week with no issues, and then I'll get corruption. Sometimes I'll get corrupt files for a day or two in a row. It's really hard to put a pattern to it.

At first I thought it was maybe my brand-new RAM and/or motherboard (unlikely, but hey)(Supermicro C2SBX and Corsair DDR3), so I ran both RAM sticks through memtest86+ and mprime seperately, and then with them both installed. I still got corruption.

Then I thought it might have been the power-supply (cause of many "random" problems with computers), so I bought a new one. I still got corruption.

I changed a few BIOS settings (BIOS/vmem caching, turned on Spread Spectrum, un-plugged the DVD drive). I still got corruption.

I thought maybe it was the tuning options for my FS (ext4) so I turned those off. Corruption.

And then I thought maybe it was the FS itself, so I moved to btrfs. The first sign of corruption on btrfs actually killed the whole FS, so it obviously wasn't the FS that I was using.

I got fed up and went to go exchange it for another one @ the store where I initially purchased it. I don't have any particularly sensitive data on my drive, but I figured I zero it out anyways. Before doing this I decided to look @ the SMART info and it didn't find anything particularly of interest, just that the arm-parking was high, but considering there isn't actually an arm to be parked I figured it was a non-issue. I ran the SMART long test a few times and it came back fine. I decided to run badblocks on it with the full write test (it writes the whole drive with a single pattern, verifies, writes again with another single patter, verifies, etc x 4) and it came back with 0 errors (side note: I'm not even sure if this is a valid test for SSD's, any thoughts on this?) One curious thing, however, is that when I was running badblocks I noticed that trying to read the SMART info would fail when trying to get the SMART logs. I also noticed that the SATA bus would try to re-negotiate the speed (SATA-150 or SATA-300). Indicitave of failure?

Anyways, I go to exchange the drive but it had been more than 30 days so they would only do an RMA for me, which they guesstimated would take ~6 weeks. I decided I would take my chances with Intel myself, so I came to the Intel communities and started browsing around to see if anyone else has had the same issue. I noticed that a few people have indeed had vaguley similair issues and they've solved it by turning off a bunch of the power-management options and AHCI in their BIOS.

I figured I would give it one more chance so I turned off AHCI and any power-management options I could find (I had to leave ACPI enabled as it turned off SMP, effectivly making my quad-core a single-core). Though I would also run the situation by you guys to see if I'm holding on to a dead drive or if the AHCI/power-mgmt disabling sounds like it will fix my problems.

Also note that I upgraded to the latest firmware before I ever installed anything on the drive, and that I threw in a new SATA cable and moved SATA ports on my mobo somewhere towards the end of all this troubleshooting.

Edit: edited for format



I would like to recommend a secure erase to this disk, you can download the bootable tool from the following link: after this you test the Solid State Drive and cannot see the Solid State Drive, I suggest you to test the Solid State Drive in a different compatible motherboard and see if it works there, if the issue persist, please contact the Solid State Drive support phone number: 916 377 7000 option 6.