Showing results for 
Search instead for 
Did you mean: 

HDDErase 3.3-4.0 and gParted Fail

Esteemed Contributor III

I tried both versions of HDDErase on my (2)X25M-G2. Both sit at the blinking cursor screen and refuse to execute the task. I have two places to select RAID modes in my bios. When I enter the BIOS I choose integrated peripherals from the Main Menu. Now I have the option to choose RAID Mode. I can choose AHCI or IDE. Now further down in the integrated peripherals menu is the option to open another menu for the On Board Controller.In this menu I now have another RAID related setting. The options are RAID,IDE,and AHCI. I tried choosing AHCI for both, and booting up HDDErase. No luck. I tried IDE for both. No luck. So I started digging and digging through tons of articles and posts. I found info about using the hdparm command in gParted and Ubuntu. I tried the latest version of gParted. The command posted was hdparm --security-enhanced-erase NULL /dev/XXX where XXX is the drive identifier. In my case sda and sdb. I think that command was outdated as I refered to the help guide in gparted which more or less said the command was hdparm --security-erase-enhanced NULL /dev/XXX And still no luck. So I took it a step further. I read in some cases unplugging the SATA cable from the drives, powering up,boot to gParted, plug the drives in, refresh the drive list, then run the command will work. No such luck. I got an input/out error. I tried sudo hdparm --security-erase-enhanced NULL /dev/XXX and still get input/output error. I tried sudo hdparam -I which says the drive is now unlocked for 2 minuetes. Still I get the input out put error. gParted recognizes three partitions. The partitions for each 80GB drive, which are both unallocated, and a single 150 GB partition with ~70GB in use. With evrything else failing, I wonder, should I delete the 150GB Partition(not format just remove), apply that,and then try hdparm?

Oh and for the record I have a P55-GD65 mobo, running the drives in RAID0, with the latest firmware.


Esteemed Contributor III

After hours of more digging I finally found Parted Magic and followed the tutorial here. I checked my drive with smart defrag, and the analysis still shows it has insansley defraged. Is this normal? Does the app just not read the blocks correctley? Going to run HDTune in a moment to check my before and after scores.

Contributor III

This is the procedure, which worked for me and my 2 Intel X-25M SSD's running in RAID0:

1. Make a complete backup of your RAID array and store it onto a hdd.

2. Create a bootable MS DOS medium (floppy, CD or USB stick) with HDDERase v3.3.

(HDDErase 4.0 doesn't work with Intel Postville SSD's)

3. Make sure, that your SSD's are connected with the first SATA ports (port0 and port1).

4. Enter the RAID ROM Utility (CTRL+I) and delete the RAID array.

4. Set the SATA Controllers of your SSD's to "IDE" or "Compatible" mode.

5. Disable the other SATA Controllers.

6. Boot off the DOS medium.

7. Run HDDErase.exe and do a secure erase with both SSD's one after the other.

8. While rebooting enter the BIOS and set the SATA Controllers to "RAID".again.

9. Enter the RAID ROM Utility and recreate the RAID array.

10. Reboot, enter the BIOS again and make sure, that the RAID is the first bootable hdd (Option "HARD DISK BOOT PRIORITY").

11. Recover your RAID backup by using the backup you have done at step 1.

12. Boot into your OS, which is on the RAID0 array.

EDIT: When I wrote my report about how I safely erased my SSD's running in RAID0 I forgot to mention, that I broke the RAID before starting the procedure and recreated it at the end.

Esteemed Contributor III

Since using Parted Magic, do I really need to use HDDErase? Parted Magic offers the Secure Erase feature, and it even works with the disks still in RAID, so I just wonder if HDDE offers any benefit over PM? As I understand it, the principal of HDDE is that it uses the Secure Erase command. PM offers this, and many other features. So from what I can see they are the same thing are they not? My benchmarks were much better this time, and Random Access scores were better as well. Although typically, random access wise, the scores were not up by much. We are talking about a matter of dropping from 2 ms to 1 ms, which is still far ahead of all my mechanical drives.

As for the tips, thanks but I already tried all of that. I made sure to disconnect the sata cables on all my other drives to be safe to make sure there was no way to format them. I tried both ACHI and IDE using the guide here. However when I got to step 3,Issue the ATA Secure Erase command, I got a permission denied error. So I tried it as sudo. Then it said sudo time was not a valid command. I tried to switch to superuser, although oddly the command prompt never changed from a $ to a # , but it still denied me permission.

Contributor III

There are some tools, which are able to do a secure erase of hdd's and SSD's, but AFAIK the only tools, which are recommended as being safe for the Intel "Postville" G2 SSD's, are the Intel Toolbox (doesn't work with RAID) and HDDErase 3.3.