Showing results for 
Search instead for 
Did you mean: 

Restoring an old G1 80GB SSD that became 8MB

New Contributor

I have an old X25M G1 80GB SSD (black case) that became 8MB and also appears to be locked, after the system underwent several lockups requiring power cycling. I don't need to recover any files from this SSD, so it can be completely erased, but I'm looking for a way to restore the capacity back to 80GB. This SSD is a "hand-me-down" that I got for free, so I'm not the original owner.

I attached this SSD as a secondary drive on a working system, but the Intel SSD Toolbox cannot see it, nor can Windows 7 OS, though the drive consistently shows up in motherboard BIOS setup, albeit as an 8MB disk, so it is not 100% bricked. I also tried running the firmware update tool but it says the firmware (8820) is already up-to-date and won't flash again.

I also tried running HDDERASE in DOS, but it claims the drive is locked and needs a user or master password to unlock, which of course I don't have.

Any help in resetting this SSD to a usable state would be greatly appreciated.


Esteemed Contributor III

Try hdat2,,not sure if this could help. Worst case, you can contact Intel for a replacement