Showing results for 
Search instead for 
Did you mean: 

P41 Plus not recognized by Motherboards

New Contributor


I recently purchased a Solidigm P41 Plus 2TB, and am excited to use it. However, when I plugged it into the auxilliary m.2 slot in my motherboard, it wouldn't even show up in BIOS. I followed the steps set out here, and didn't have any luck. I tried it in two different computers, each with two different slots where prior m.2 NVMe drives did work. The two motherboards I checked are the Asrock Z590M Phantom Gaming 4 and the ASUS TUF Gaming X570-Plus WiFi, neither of which had the P41 plus show up either in Windows 11 or in the BIOS itself. I tried using the Solidigm driver setup provided on the website, which didn't recognize the drive, as well as the boot drive tool for updating firmware, which also did not see the drive.



Hello dannys4,

Thank you for contacting Solidigm Support.

We are sorry that you are experiencing issues with your Solidigm P41 Plus 2TB. We will do our best to help you with this problem.

Once we receive your response, we can continue to assist with your case.

Remember that you can always contact us via phone or chat!

USA: +18333137337
Language: English and Spanish
Hours of operation: 8:00am - 5:00pm PST
(Daylight Saving Time: 7:00am - 4:00pm)

Solidigm Customer Support.


New Contributor

Hi Yordan,

I just tested it again to check I was using the PCIe4 slot-- the drivers that you linked are, indeed, what I installed. Also, when I install them with the SSD plugged in, the driver installation module does not see the drive (before, during, or after installation). For reference, I was planning on using this as a secondary storage drive.

Hello dannys4,

Thank you for contacting Solidigm Customer Support. Our team has contacted you to resolve your issue, please check your email.

Thank you for choosing Solidigm.


Dzmitry Solidigm Customer Support  




New Contributor

Looking for same got me here.  My issue was simple stupid me, make sure the m.2 is well seated.  Not just enough to install the m.2 screw, but in my case there was an extra bump to clear.  Hope this might save someone a returned item.