Showing results for 
Search instead for 
Did you mean: 

X25-M Gen2 worked fine, now not recognized in BIOS

Esteemed Contributor III

I was using my 80GB X25-M G2 {SSDSA2M080G2GC} for 5 months and it worked very fast and very good with no issues until last night. The drive now is not recognized in the BIOS and when I boot with it I get "Operating System Not Found" I did not update the firmware on the drive so I believe it had the OEM version. Any ideas on retrieving the data or getting the drive to recognize.

Sony Vaio VGN-BX670P, Core 2 Duo T7200, 2GHx, 1.50 GB of RAM, XP Service Pack 3.


Esteemed Contributor III

Hi, I expenrienced the same issue and surfing the web investigating I may found the issue that related with BIOS restrictions made by VAIO.

I succed making SSD working just once and after reboot BIOS didn't recognize anymore the device, once cleared NVRAM it see just once the device.

Some users fixes the problem enabling "AHCI Optional Rom Support" accessing BIOS file and editing that, that sounds kinda risky but It could help.

Anyway it depends from the BIOS notebook have installed, my VAIO SR21M/S got American Megatrend BIOS that is more difficult to edit, if you got Phoenix BIOS it will be easier.


Esteemed Contributor III

Intel said my drive went bad and replaced it. Lost all data. The turnover was fast - 4 days but I still lost all my data.