Showing results for 
Search instead for 
Did you mean: 

Intel 520 - Password not accepted after restart

Esteemed Contributor III


I installed new Intel 520 SSD into my T420s and it works great with one exception - HDD password configured in BIOS is not accepted after restart. Both user and master passwords were configured for the drive but none is accepted after restart.

There is no issue with password when laptop is powered on or resumed from hibernation.

I had Intel 320 SSD before and it worked correctly in the same setup.

Thank you for help



Esteemed Contributor III


I have exactly the same problem. Switching from a 320 to a 520 the SATA password is not accepted after a restart on a Lenovo x220

With best regards, Lars

Esteemed Contributor III

I'm having the same problem with a ThinkPad W530 and an Intel 520 SSD. The password is accepted if I shut down completely, but not after a reboot.

Esteemed Contributor III

If the BIOS is asking for the ATA, SATA, HDD, etc. password on just a reboot, sleep, hibernation, etc., the BIOS / software has surely sent the drive the lock command. In the high security mode (passwords are set), you have to actually power down the drive to release that.

Encrypted drives, their commands, and how they interact with various versions of BIOS are not completely figured out. Odd things like this are pretty common. There are few possible things to try with the usual giant warnings and cautions involved in trying to change anything...

1. The computer maker might have updated BIOS that fixes this.

2. The software that is shutting down the computer might have shutdown options that will not lock the drive.

3. The BIOS security or HDD settings might be able to disable hard drive locking on a simple reboot.

4. You might try some live CD like Linux to see if it still does it. That would tell you if it is in the BIOS or something the running software is doing.

If it really bothers you a lot and none of the above show any hope, you will probably have to disable hibernation, sleep, etc. or remove the ATA passwords. Of course, then you lose the high security all together. If you need the security, you will have to just cold boot and you might as well just set the computer to turn off all the time if you are not using it.

There are actually good arguments for doing it many ways. Unfortunately, there are often not user options to set it the way "you" want...

BTW - No Secure drive will accept the ATA password after cold boot anyway since any simple spy software could easily steal the password then. You have to avoid letting the BIOS or software secure locking the drive if you want to be able to warm reboot.

Esteemed Contributor III

piranha, I believe you misread the original post. It's true that the computer asks for the password upon a reboot, even if the BIOS setting for that is disabled, but the real problem is that the correct password is not accepted at the prompt. You have to power off the machine entirely and then turn it back on before it will accept the correct password. Having to enter the password after every reboot is annoying, but not nearly as annoying as when it asks and won't accept the correct answer.

This happens from both Windows 8 and Xubuntu 12.10, so it's not an operating system problem. It does NOT happen if you reboot from the BIOS screen, however.