Showing results for 
Search instead for 
Did you mean: 

Trouble with 2 x Intel 520 (180GB) RAID0

Esteemed Contributor III

Hello there,

I recently purchased a pair of Intel 520 SSD's to start using in RAID0 (they will replace my current Intel 510 SSD's).

After installing and restoring my OS partition al seemed well, however after a day or so i suddenly had a system crash.

All windows programs stopped working one at a time, and all i could do was reboot.

After the reboot, the Intel RAID BIOS showed me an "Error" on one of the new drives.

To my amazement the Windows installation did still seem to work on the RAID0 array and booted without any problems.

After logging in, i was greeted by a notification balloon from the Intel RST software stating one of my drives had given errors.

I could open the application and click a link called "Set drive back to normal mode". The 'error' (or malfunction) dissapeared and

all seemed well again.

I suspiciously took this for granted, hoping this was the last of the issues i would see. Unfortunatly this wasn't the case.

A day or so later, the exact same 'error' occurred again.

This time, my OS would no longer load and i would get the message we all know... (Reboot and select proper boot device or insert boot media in selected).

So here I was, with a RAID0 array + Windows installation that was no longer working.

I hooked up my old RAID0 array (2 x Intel 510) again and started searching for some information / answers.

Among these answers i saw a topic somewhere on these forums that had a few tips which i all followed up. Those tips were:

- Delete the RAID 0 array so the Intel 520's would be seen as normal/single drives.

- Install the Intel SSD Toolbox (The latest available v3).

- Check if the drives have the latest available firmware (they did).

- Run a full diagnostic scan (did it twice for each drive and 1 drive didn't pass the first time, but they both passed 100% the second time).

- Do a full secure erase on both drives.

- Left the drives hooked up to my test system for a few days to see if anything would happen. No errors.

- Recreated the RAID0 array (without installing anything on them) on my test system for a few days to see if anything would happen. No errors.

Now to follow up testing the drives without any pressure i installed them both onto my secondary PC (where i also did the tests).

I recreated the RAID0 array and restored my Windows partition again.

All seemed fine at first, until only like... 120 mins later the exact same error showed up again.

So this time the RAID array was giving the exact same failure on my secondary computer system.

I hope anyone here will be able to help me solve this issue or rule out any bad drive.

I must honestly admit this does not make my gut feel any better about the first Intel Sandforce controller drives.

I have a pair of X-25M G2's and Intel 510's before and _never_ had a single problem with them, ever.

On a sidenote...i have read some people report that turning off Intel Linked Power Management functionality could perhaps solve these sort of issues.

Why on earth would an Intel SSD fail to work with functionality developed by the same company? And, if someone can indeed confirm this is the case...when can we expect this to be fixed the 'official' way?

To give you an idea, here is some additional information of the machines i use:

Primary machine:

Gigabyte Z68X-UD7-B3 (Intel Z68 Chipset)

Intel Core i7 2600K

2 x 4 GB G.Skill Ripjaws-X PC12800

Seasonic X-850 PSU

Gigabyte Radeon HD7970

Current disk set: 2 x Intel 510 (120GB) RAID0

Secondary machine:

Asus Maximus Formula rev. 2 (Intel X38 Chipset)

Intel Core 2 Quad Q9650

4 x 2GB OCZ ReaperX PC6400

Seasonic M12D-850

Sapphire Radeon HD5850

Current disk set: 2 x Intel X-25M G2 (160GB) RAID0

Thanks in advance for any help.


Esteemed Contributor III


Esteemed Contributor III

I have two 180GB 520s in RAID 0, and they are working fine. Have you noticed in the IRST Windows GUI, you can run a "Verify" data test? While that is meant more for RAID volumes other than RAID 0, it also seems to check the storage medium itself, not just the data. Sure, not any better than the Toolbox diagnostic, it would be a "second opinion". Also another workout to stress the SSD, and cause it to fail if it is borderline.

You could have tried a Windows repair with the installation media, although corrupted Windows files does not seem to be the problem. Did you use different cables, including power source, to those SSDs?

Intermittent problems like this are difficult for a PC owner to diagnose. I would exchange the SSD and don't waste time with it. If the issue repeats with a new SSD, then more fun begins...

Esteemed Contributor III

Hi guys,

Thank you for your replies. Since i have not gotten any replies sooner i also took this issue up with Intel Support themselves.

I am not trying to troubleshoot with someone from them as well.

I will follow up on your advice and try to verify the drive a few times again (as well as stress testing it).

I still have the feeling a sort of power state or power saving option is causing the issues and not the actual quality of one of the drives. Though one of the drives failing the diagnostic test might not be a good sign indeed.

New Contributor II

Run a full diagnostic scan (did it twice for each drive and 1 drive didn't pass the first time, but they both passed 100% the second time).

That right there is probably a bad sign. Just because it passed a second time doesn't necessarily mean the drive is okay. I'd exchange the drive that failed the test and see what happens.