Showing results for 
Search instead for 
Did you mean: 

Intel SSD 520 240 GB problems

Esteemed Contributor III

I received my Intel SSD 520 240 GB mid-June, and since then, I have been nothing but frustrated with this SSD and Intel's email support.

First off, let me start off with my system specifications:

Asus U20A Notebook

Intel Dual-Core ULV SU7300 1.3 GHz

Mobile Intel GS45 Express Chipset + ICH9M

4 GB DDR2-800 RAM

Intel GMA X4500MHD Graphics

Before upgrading to this SSD, I ran a 320 GB HDD in AHCI for 3 years on Windows Vista, and later, Windows 7 with absolutely no problems. After upgrading, I freshly installed Windows 7. The installation went without issue, but upon booting up into Windows, my system would frequently pause/freeze/stall for a minute-or-so, then resume for a few minutes only to pause again. I could still move the mouse, but running application would become completely unresponsive.

After multiple re-installations of Windows, updating Windows (which took all night with all the frequent pauses) and installing IRST drivers, the problem still remained. After installing Intel SSD Toolbox (took 15 minutes) and running a full diagnostic scan on the SSD, it came up with read errors within a few seconds. I RMA'ed the SSD only to have its replacement do exactly the same thing.

So now I'm thinking maybe it's my notebook. So I tested the new SSD in my older desktop with the following specifications:

Shuttle SG33G5

Intel Core 2 Quad

Intel G33 Chipset + ICH9DH

4 GB DDR2-800 RAM

Intel GMA 3100 Graphics

The SSD ran perfectly.

So with the SSD back in my notebook, and after some troubleshooting, I discovered that if I run the SSD in IDE mode, the pauses do note happen. Still unsatisfied, as obviously the SSD is much slower in IDE mode, I took to the forums in-search of a fix as Intel's email technical support is totally and utterly useless.

I found on Corsair's SSD support forums that one of their SSD that also uses the SandForce controller was suffering from similar pauses. The fix (discussed here) was disabling Link Power Management (LMP) and it worked. Since then, Corsair has released a firmware update that addresses this issue. You also need to disable Device Initiated Power Management (DIPM) in the Intel SSD Toolbox, or else the pauses come back.

The fix is specific to the IRST drivers and involves modifying values within HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\iaStor.

With the pauses fixed, now I am having another issue: I am getting a BSOD with STOP 0xF4 after resuming from sleep. Again, I took to the forums, and unsurprisingly, an OCZ SSD that also uses the SandForce controller was suffering from the exact problem (discussed here). Just as Corsair did, OCZ released a firmware update to address these issues.

So besides disabling sleep, how do I fix the this BSOD STOP 0xF4? When is Intel releasing a firmware update to address these SandForce-related issues?

Also, below is my email communique with Intel technical support, just in case anyone is thinking that they will be useful.

Hello Marc,

Thank you again for contacting Intel Customer Support.

It is not necessary, they are in the previous emails.


Mark B.  

Intel Technical Support

Original TextFrom:<<snipped>> 09:41:39Subject:Re: {ticketno:[8000475687]} - Your Intel Customer Support Inquiry

Can you please reiterate your recommendations?

On Jul 18, 2012 12:33 PM, <</span> SUPPORT.REPLIES@mailbox....


Esteemed Contributor III

Starchild is not the only one having this issue. Last Thursday I received my brand new Dell Precision M6600. Before I started to use the system I upgraded the hard drive to an Intel 520 Series..

After dropping in the SSD, I was ready to install Windows 7 Pro. I first went into the BIOS and left the setting on RAID. After reading tons of forums, this seemed like the right way on installing the hard drive. Once complete I installed all the necessary drivers (which is a story in its self!). After, I went on the Intel website and ran the driver utility make sure everything is up-to-date. I also installed the SSD toolbox to optimize the drive.

After dealing with the BIOS not always detecting the SSD and the occasional OS freeze, I made my way into the Intel control panel. I noticed the hard drive was only running at 3GB/s, I thought that was kind of odd since the computer is capable of running 6GB/s. I decided to change the BIOS to AHCI and reinstall 7..

Once complete I still had to deal with the BIOS not detecting the SSD and 7 freezing up every so often. Anywho, once I re-installed all drivers and utilities. I now see the hard drive running at 6GB/s. I was a very happy camper until I started to use the computer. I noticed it freezed up the more I use it.

Finally, after I finished reading all documents I could find on the internet on my trusty apple. I decided to post this issue on the Intel forum. Approximately 13 hours later, Starchild wrote me back two possible ways of correcting the issue. One was the power management options in windows and the other was a registry modification. I couldn't find the power management option; skeptically I went ahead and modified the registry. After I rebooted the computer now works perfectly!

Intel (typing this while simultaneously shaking my pointer finger) you have a serious issue with your SSD. You need to post a firmware update. Not only to fix the issue with 7 but, also so folks who have M6600 and other affected laptop/desktops; who decide to buy your SSD, can just turn on the computer and have it boot up normally.

Thanks Again Starchild..

New Contributor III
New Contributor III


Please note that if not using RAID, you do not need, and should actively avoid the Intel RST drivers. There is zero performance difference between using the Windows built in ACHI drivers or the Intel ones. I've had several issues over the years using Intel drivers for ACHI including blue screens that have all been fixed by using the Windows built in drivers. Check out Intel's own release notes, they often document known issues for various problems and are being updated every few months in a desperate attempt to fix issues, whereas Windows built in drivers rarely require updates and when they do, they are part of a very heavily tested service pack or update.



Esteemed Contributor III

I switched to MS' AHCI drivers and the pauses returned. With all the pausing, it took more than an hour, but I was finally able to enable control of DIPM/HIPM in Power Options via the registry (discussed here). From there, I disabled DIPM/HIPM for each Power Plan and the pauses stopped. I have also successfully resumed from sleep without a BSOD STOP 0xF4. Additionally, I went from 7.7 to 7.8 primary hard disk Windows Experience Index subscore.

So far, switching to MS' AHCI drivers have solved all my problems. Thanks for the help Phil!

Esteemed Contributor III

Thanks Phil and Starchild for the additional help, I'm still new to troubleshooting these issues so I really appreciate all the feedback!! I'm currently using the "Intel(R) Mobile Express Chipset SATA AHCI Controller", I will try the "Standard AHCI 1.0 Serial ATA Controller". Hopefully soon Intel will come out with a revision that solves all issues.

Also, I have heard a lot about TRIM how can I tell if the TRIM option is running?

Thanks again


The computer is still having issues, it continues to freeze while surfing the web.. On the bottom it says "waiting for cache"