Showing results for 
Search instead for 
Did you mean: 

How to Migrate a Vista x64 C: Partition from RAID1 HDDs to an Intel X25-M (G2) SATA SSD?

Esteemed Contributor III



I have a Dell Precision T3400 running Vista x64 Ultimate SP2 and the latest Dell Flash BIOS A11.It has two Western Digital 500GB SATA 3.0Gb/s hard disks configured in as RAID1 managed by an Intel ICH8R/ICH9R Raid controller.The dual HDDs are logically partitioned into C: and B: drives.I have Acronis True Image Workstation and take regular snapshots of my C: drive and have created a bootable CD-ROM.But, my C: partition is only 60 GB and has only 2 GB of free space remaining and I need to increase its size. So, I purchased a 120GB Intel X25-M SATA Solid-State Drive (SSDSA2MH120G2K5) and installed it into the empty 3.5 inch HDD bay.I connected the SSD to the power cable and plugged the data cable into my empty SATA-4 slot on the motherboard. PROBLEM  My BIOS does not recognize the SSD as a SATA device. I need step-by-step instructions on how to get my system to recognize my new SSD and I'm hoping to get answers to the following questions along the way:
  • How do I made sure my HDDs are still a RAID1 pair after the migration?
  • Do I need to unplug my HDDs from ports SATA-0 and SATA-1 before connecting my SSD?
  • Do I need to connect the SSD to port SATA-0?
  • Do I need to enable ACHI in the BIOS? If so, how and when?
  • When do I use Intel's SSD Firmware Update Tool to upgrade the SSD firmware?
  • When to install the Intel SSD Toolkit with its SSD Optimizer to get TRIM-like garbage collection under Vista?

BIOS Settings

Currently, my six SATA ports are allocated as follows: SATA-0 = 500GB Western Digital HDDSATA-1 = 500GB Western Digital HDDSATA-2 = TSSTcorpDVD-ROM TS-H353BSATA-3 = TSSTcorp DVD+/-RW TS-H653BSATA-4 = Intel X25-M SSD (unrecogized)SATA-5 = not used SATA Operation is set to RAID Autodetect / AHCI = RAID if signed drives, otherwise AHCI The boot sequence is set to: 1. Onboard or USB Floppy Disk (not present)2. Onboard SATA Hard Drive (not present)3. Intel ARRAY4. Onboard or USB CD-ROM Drive5. Onboard Network Controller (not present)6. USB Device My Windows Vista x64 SP2 registry entry for [HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Msahci]Start = 0x00000004 (4)

Esteemed Contributor III

If you are in RAID with the ICH9R or ICH8R, then your SATA controller is already in RAID mode. This is a superset of ACHI. Also, it does not matter which SATA port you use on a controller.

You should definitely flash the firmware before installing anything on it. While the update is non-destructive, there is always a risk. You have to flash it while in IDE Mode.

SATA devices do not show up in the BIOS since they are "under" the controller. If you hit CTRL+F6 (I think that's it) to enter the RAID screen, you should see the SSD.

Intel provides a Data Migration Tool (license from Acronis):

It will allow you to clone your existing C: drive and expand it to 111.76GB.

Esteemed Contributor III

My apologies for not responding sooner to your post, DuckieHo, but my Intel login credentials stopped working after I started this thread and I didn't realize I could respond without logging in until now.

Here's what I have tried so far:

1. Created a CD-ROM of the Intel® SATA Solid-State Drive Firmware Update Tool

that I downloaded from

2. Changed my boot sequence so that my PC would reboot rom the CD-ROM.

3. Shut down the system, waited 10 seconds, then rebooted.

4. The PC rebooted from the CD-ROM and the utility started to run. But, then it reported nothing but errors. Unfortunately, I did not write them down.

I'm planning on repeating the steps above while my RAID1 HDDs are not plugged into the SATA-0 and SATA-1 ports.

Esteemed Contributor III

Here's what I just tried:

1. Shut down the system.

2. Disconnected both RAID1 HDDs from the SATA-0 and SATA-1 ports.3. Connected my Intel SSD to the SATA-0 port.4. Booted off the Intel Firmware Update Tool CD-ROM.

I got the following error messages:


illegal partition table - drive 00 sector 0illegal partition table - drive 00 sector 0CONFIG.SYS error in line 0

Esteemed Contributor III

Just to add to what I reported earlier when I tried to boot from the Firmware Update Tool CD-ROM after disconnecting my RAID1 HDDs:

According to the SATA_SSD_Firmware_Update_Tool_Guidelines.PDF, the system should automatically load FreeDOS and start the Firmware Tool Automatically. It should display the following prompt before I have to do anything:

Intel Corporation (R) Firmware Update Tool Version X.X

Copyright (c) 2009 Intel CorporationHave you read the license agreement on the web page or README.txt file included on this CD (y/n)?: