Showing results for 
Search instead for 
Did you mean: 

Intel P3700 PCIe 800GB SSD does not work with CentOS 6.6 or 6.5, but does work with 7.0.

New Contributor

I am running a new P3700 800GB SSD in the primary 16x PCIe graphics slot in a new Dell precision T1700 workstation. I started off trying CentOS 6.5 and 6.6, but I could not format it with either. I started out trying the GUI disk management tool and it would just hang when I attempted to modify the drive. Then, I tried "parted" and "mkfs" to partition and format the disk. When I attempted to create the partition, it hangs and then exits with IO errors, at which point the entire device is no longer visible with "lspci" anymore. When I loaded CentOS 7.0, it worked fine; partitioning, formatting, and general use. This confused me a bit, since 6.5 was supposed to support nvme and 6.6 reported nvme driver version 0.9 with modinfo, whereas CentOS 7.0 reports nvme version 0.8. This was reproducible with a second P3700.

Is there a known issue with this drive and the 2.6.32-x kernel used in Red Hat 6? I haven't gone looking through any kernel logs, but I wasn't even sure if the mainline upstream kernel 2.6.32 even had this driver in it or if it was added by Red Hat. Thanks for any insights.


New Contributor III
New Contributor III

The Intel's Linux NVMe Driver Reference Guide mentioned building the driver for linux kernel 3.10.0 and above. Intel® Download Center mentioned that the working Linux driver is included starting from kernel 3.3

Since CentOS 6.5 and 6.6 is using kernel 2.6, most likely whatever included driver (backported?) may not function properly.

In your case it would be better for you to use CentOS 7.0 (kernel 3.10) for best compatibility.

New Contributor

Thanks for the reply.

I agree and I have read those docs before. I was just surprised to see Red Hat advertising this feature in their notes and seeing a driver for it in the OS, which would be nice for us since we are going to have several machines in our lab standardized to Cent 6 for a long time for some other reasons. NVMe may not be a real, supported feature, though, and since we are running CentOS, I'm not expecting any support. I just wasn't sure if there was some sort of parallel development for kernel 2.6 and 3.x or if the 2.6 driver really was just an unsupported backport of the driver in 3.0 done by Red Hat people. I wanted to make sure that I haven't just missed something obvious. There do appear to be people using NVMe in CentOS 6.6 successfully, though.