Showing results for 
Search instead for 
Did you mean: 

Firmware update for 600p caused blue screen

New Contributor

OK, so I got an Intel 600p 512GB M.2 ssd the other day. And it appears to be running happily on my Gigabyte GA-Z97MX Gaming 5 motherboard. Got my Windows 10 Pro x64 installed, updated, drivers installed, etc. Everything running as it should.

However, I finally got around to installing the latest Intel SSD Toolbox software and figured I would update the firmware on it. It came with PSF100C out of the box and saw that the lastest is PSF109C. Seeing how this drive supports firmware updates from within the app I ran it and here is where my heart attack began. It sat at 5% for about two minutes and then caused Windows to blue screen and crash. Nothing could be done at that point. I rebooted and the system would no longer POST. In the BIOS I no longer had any NVMe drive option. I quickly tried burning the firmware update onto a CD via another computer but no go, it wouldn't see the drive at all in that.

However, and here is where it gets weird, after fully powering down at that point and then powering back up, the drive was suddenly recognized again and upon getting into Windows reports itself as having PSF109C now.

But I really have my doubts that the firmware flashed correctly. Is there a way to force the same firmware to write again with the self-booting CD? I'd love to be able to get piece of mind because the way it stalled and crashed, I'm not confident it wrote properly.


Esteemed Contributor III

Hello Nogib,

This is a rare situation, we have been able to update the firmware on our SSD 600p with no issues (Using Firmware Update Tool & Intel® Solid-State Drive Toolbox).In your case, it is clearly an isolated situation that, for some reason, the update was applied. Normally, the SSD should be not even working after a failure while running the firmware update.If you try to boot the ISO containing the firmware update, the system will check and let you know that the latest firmware is already installed, a reason why there is no way to "force" the installation.We do suggest to keep testing and checking the SSD, and when a new firmware is released, please apply it using the FUT (Firmware Update Tool).Let us know if you have any more questions.Regards,NC

New Contributor

I just had this EXACT same thing happen to me, hung at 5% then blue screen. Upon reboot it wouldn't go past bios and didn't recognize the drive. Reboots did nothing Full power down and I got it back. I just finished this build and it had been running for less than 30 mins.

Shows firmware PSF109C Installed now.

Esteemed Contributor III

Hi KingPhoenix,

We would suggest to you to please create a case with our support team and provide a brief description of this situation. We'll be waiting for your response.Regards,Nestor C

Esteemed Contributor III

Hi Nogib,

We would like to know if you require further assistance about this situation? We'll be waiting for your response.Regards,NC