Showing results for 
Search instead for 
Did you mean: 

X25-M 80gb G2 not detected in BIOS on acer aspire 6920

Esteemed Contributor III

I purchased a new SSD yesterday to put in my laptop, and acer aspire 6920, but I have a problem with it being detected in the BIOS or with the windows installation.

I have tested the drive on two other machines of mine (desktops), and it is detected and works fine. I have tried using IDE instead of AHCI in the BIOS, but that did not help. I also tried updating the BIOS on the laptop, and that did not help as well. The SSD does have the most current firmware as well.

Is there any way to make this drive work in this laptop? What else should I try to do to make this work?

Thanks for any input.



Have you formated the drive NFTS ??

Esteemed Contributor III

Well, right now it will not even show up in the BIOS as anything, and windows 7 install cannot see the drive to try and format either. So no, I have not formatted the drive yet.

I am wondering if maybe the SATA controller on this laptop is incompatible (though it is an intel machine)?

NO these drives will work on SATA 1.5 or SATA3.0, Do you have another computer you can use to format the drive??

Have you tried starting the laptop with the windows disk in the machine to see if it will boot form disk ??