Showing results for 
Search instead for 
Did you mean: 

Unable to install RST (Z77 Fatal1ty Pro + 520 Series 120GB SSD)

New Contributor

Hello there, I'm trying to get RST installed, but have not had much luck.

I downloaded 'iata_enu_10.8.0.1003.exe' from here. When I run this, it tells me 'This computer does not meet the minimum requirements for installing the software'.

So I then downloaded '' from here. I get to the Windows install screen, click load drivers, located where I saved the drivers on my USB (unzipped). When I open this folder and tick the hide drivers which are not compatible with my system, it does not display anything.

When I untick this option, it displays about 15 drivers.

I noticed one of the options has 5 series chipset in the name, shouldn't there be one for 6 and 7 series chipset?

SATA are set to AHCI. When I set to RAID and tick the hide option, it lists 'desktop/workstation/server express Chipset SATA RAID controller'.

So with that, I set to AHCI and tried the desktop/workstation/server express Chipset SATA AHCI controller' option, but I'm still not able to install RST.

Any help would be great, thanks.


New Contributor III
New Contributor III


Are you wanting/needing to use RAID? If not, the Intel drivers provide you with nothing really, and are often more buggy than the default Windows drivers.

First off I would ensure your PC has the lasted INF files to identify the chip-et components to Windows, by default your controller for ACHI mode show show correctly. The latest chipset drivers are here: Download Center

You should then see in device manager in ACHI mode under IDE ATA/ATAPI Controllers the entry similar to "Intel(R) Series/C216 Chipset Family SATA ACHI Controller".

If you don't need RAID, this is all you need to do. There is no performance advantage to Intel drivers, they are only need if you need to enable RAID.



New Contributor

Apparently RST is already installed. I check the system tray and it's got Rapid Storage Technology there with the tick.It must have installed with the mobo drivers and utilities. Dunno why I would be getting that message when trying to manually install it, though..

Thank you, though.

Esteemed Contributor III

Your Z77 chipset uses the IRST release 11... drivers, and the IRST 10... drivers are older, so that is why you saw that message when trying to install The earlier 6-series chipsets use, or newer. Yes, that error message does not help at all regarding what the issue is.

You actually will not get all the special features that Z77 chipsets have if you don't use a release 11 IRST driver, so that is one reason to use it.

Next, any IRST driver is also the Intel AHCI driver, since AHCI is a subset of RAID. It does no harm to use RAID mode if you never create a RAID volume, since single drives used in RAID mode are treated as being in AHCI mode. TRIM will reach a SSD not in a RAID volume if you use RAID mode. Intel designed and created the AHCI standard, and licenses it free.

Yes, if you don't install a SATA driver when in AHCI mode, Windows 7 will install it's own AHCI driver, msahci. What's better, IRST or msahci? You tell me...