Showing results for 
Search instead for 
Did you mean: 

Toolbox cannot run optimizer on RAID - no RAID Installed

Esteemed Contributor III

Hi all, here's my system: dual Opteron 6170s on Asus KGPE-D16, 24gb Kingston ecc Vauleram, Quadro 2000, Intel 120gb X25-M with Win 7 and latest updates, 500gb Momentus XT, 2tb Seagate sata internal, 1tb Seagate esata external. I think I've got the latest firmware installed for the ssd.

When I try to run the optimizer from the toolbox, it tells me it cannot be run on a RAID configuration. All 6 ports are running in AHCI mode, so I don't know why the RAID message is displayed.

If I've not provided enough information, please ask, and thank you for any advice you can give.


Esteemed Contributor III

I was running AMD sata controller. I installed msahci.sys and optimizer now runs.

Esteemed Contributor III


Is not a solution to install the generic driver.

I have exactly the same problem..

A bug of one year...

Whitout the amd driver, the ssd speed was "lost"...

Please fix this bad détection of the système by the toolbox..

New Contributor

Hello from France,

I have exactly the same problem.

MoBo ASUS M5A97 Pro with an AMD Athlon X6 1075T.

Chipset AMD SB950 with the latest dririver date 04/11/2012 for SATA III.

Running in Windows 7 Pro.

I just can use optimizer in IDE mode, not in AHCI.

The SSD just works in SATA II at 3 GB/s ( impossible to get it work at 6 GB/s ) though I have a WD Caviar Black HDD that works in SATA III at 6 GB/ and it's the same in IDE mode.

Haven't yet tried the Microsoft generic AHCI driver but not sure to try from what I have read.

I have tried the SSD on an ASUS P8Z77-v MoBo with an Intel Z77 chipset and SATA III drivers up to date in AHCI mode but not as a system drive and the speed is 3 GB/s instead of 6 GB/s.

So as many I can't run the Intel optimizer but what is strange is that it doesn't want to run at 6 GB/s.


Hi Spirou38,

We are looking into the issue with optimizer on AMD systems. I'll keep this thread updated with information as it becomes available (no timetable for resolution has been identified).

For your issue with your SSD only running at 3GB/s, what model of SSD do you have. This thread was started by a customer with an X25-M. Is yours the same? If so, then the drive is operating normally since it's on board controller is only SATA II.

If you have a different model then you should contact Intel Customer Support. You can find contact information on this page: