Showing results for 
Search instead for 
Did you mean: 

SSD 330 60GB not recognized on C600 chipset

Esteemed Contributor III

Hi, I have an Intel SSD 330 60GB SSDSC2CT06 in a SuperMicro 7047A-T workstation.

The machine uses a SuperMicro X9DAi motherboard that uses an Intel C602 chipset.

The chipset driver installed a SATA and SAS storage controller:

Intel(R) C600 Series Chipset SAS RAID (SATA mode)

Intel(R) C600 Series Chipset SATA AHCI Controller

The OS is Windows 7 x64 Ultiamte SP1.

When I run SSD Toolbox v3.0.3, it detects the drive as:

Model: Unknown 60GB

Sirmware Version: 300i

Serial Number: [Redacted]

How do I get SSD Toolbox to correctly recognize the drive?



Esteemed Contributor III

There are a couple possibilities why your SSD 330 is not recognized in the Toolbox.

First, given the chipset you use, C602 (aka X79), you are probably using the Intel RSTe driver, is that correct? If so, that is the problem. Other X79 board users have found that when using RSTe, the Toolbox does not work correctly. Apparently, the RSTe driver, or current versions of it, was not meant to work with the Toolbox, or simply doesn't for some reason. X79 boards are the only PC type boards that use RSTe, but it's still strange that a version for PCs that supports the Toolbox has not been released.

Much less likely is that the 330 SSD is not yet supported by the Toolbox, but that would really be strange, since the Toolbox works fine with the new 520 SSDs.

Do the Toolbox functions work with the 330 and your chipset/driver? We still need to verify what driver you are using. Since Intel does not really provide separate drivers for AHCI and RAID, at least in the PC world, I'm guessing you are using RSTe, but that needs to be verified.

Esteemed Contributor III

That is correct, I do use the RSTe drivers and Storage Manager utility.

The drive is correctly recognized by the toolbox when used in a different system that uses the retail drivers.

It is not possible to use the retail storage manager, I tried, the Storage Manager app crashes when launched.

We need a new version of the toolbox that supports C600 chipsets and RSTe.


Esteemed Contributor III

Yes, really a given that you were using RSTe. As you've seen, it's RSTe that is the problem.

There is a potential fix for you, although I have not done this myself, as I don't own a X79 chipset board. Some forum acquaintances of mine say that they have manually loaded the iaStor driver file (iaStor.sys) taken from one of the IRST release 11.x driver installation files (used with the other Intel 7-series chipsets.) That allows the Toolbox to function correctly on their X79 boards.

They use either the iaStor.sys file from the file (or other IRST release 11 f6flpy... zip file, that's the latest) or using a command line option on the standard STOR_Win7...exe IRST installation file that simply extracts the component files from the installer (explained in the Readme file.)

The iaStor file is installed in Device Manager, by manually updating the driver. As I recall, the driver file will be considered incompatible by Windows, but can be installed anyway. I would suggest searching the Internet for examples of this process.

I'm not sure, but you may be able to change to the Windows 7 standard AHCI driver, msahci. That should allow the Toolbox to work normally, but Windows IRST GUI will not work with msahci, AFAIK.

New Contributor

I have had the same problem, and an update of the RSTe drivers actually solved it for me. I have a Gigabyte GA-X79-UD3 mainboard with Intel X79 chipset and C600 storage controller, along with an Intel 330 180GB SSD. The essence of the problem seems to be that even though in the BIOS configuration the storage controller was configured for AHCI mode, the RSTe driver reported that it was running in RAID mode, which doesn't support S.M.A.R.T., and hence the Toolbox won't work either. You can check this by opening the RSTe GUI, selecting the C600 chipset and looking at the Mode reported on the right window pane.

The most recent version of the RSTe driver is from the 31st of July, 4 days after the last reply in this thread, so it's possible that this was the first version to fix this problem. From Intel's Download Center, download and install Intel® RSTe AHCI & SCU Software RAID driver for Windows* v3.2.0.1135. Already during installation, I noticed that apparently only the AHCI mode driver was installed anymore, so the installer seems to have correctly detected the BIOS setting. Sure enough, after a reboot the RSTe GUI reported AHCI mode where it used to say RAID, and now the Toolbox works.