Showing results for 
Search instead for 
Did you mean: 

Error: RAID array detected... Intel SSD Toolbox

Esteemed Contributor III

I Just installed my new Intel SSD 520 Series 480GB Drive (SSDSC2CW480A310) and installed the Intel SSD ToolBox. When I run the SSD Optimizer I recieve the following Error: "Error: RAID array detected. If RAID array not present, reboot and try again". My system is as follows:

Lenovo 4270CTO BIOS: 8BET55WW (1.35 )

Intel(R) Core(TM) i7-2960XM CPU @ 2.70GHz

SSD: INTEL SSDSC2CW480A3 Firmware 400i

Intel(R) HD Graphics Family 3.76 GB

NVIDIA Quadro 2000M

Microsoft Windows 7 Professional (64-bit) SP1

32GB DDR3-SDRAM (1333 MHz)

I do not have a RAID configuration.

Thanks -


Esteemed Contributor III

Strange and then maybe not, laptops can have all kinds of odd SATA issues.

Actually, your issue is known to exist on another laptop, a Dell. That is documented in the Toobox Installation Guide, here:

Have you asked Lenovo about this problem? Can you get into your laptops BIOS and see what the SATA configuration is? I assume you tried to reboot, but nothing changed?

Esteemed Contributor III

add to the list an HP pvilion g7-1219wm. same thing happening with my series 320 120gb...

Esteemed Contributor III

joe, Sorry to hear that. In other words, you cannot use the Toolbox functions usually available for a single SSD?

In case you don't know, the Toolbox does not offer its usually functions to SSDs in a RAID array, even if they are Intel SSDs. Simply having the SATA mode set to RAID does not cause this, since single (non-RAID array member) Intel SSDs will have all the Toolbox options available to them, they are basically operating in AHCI mode.

Whatever way the Toolbox determines a SSDs configuration, is apparently failing in your case, and for the OP too. Perhaps a protocol not being adhered to, or data missing or corrupted, is causing your issue. Not that you have done that.

If your SSD is connected to a SATA chipset other than an Intel, that usually causes the SSD to be undetected by the Toolbox.

Esteemed Contributor III

thanks for the info parsec. my laptop has only one drive, and that's the ssd (well, it's also got a card reader and an external usb mechanical storage drive connected, but that shouldn't make a difference). this drive was formerly in a self-built desktop pc and had no difficulty, but the toolbox was an older version. this is occurring with ver 3.0.3 of the toolbox, so I may try an older version and see what happens.