Showing results for 
Search instead for 
Did you mean: 

330 ssd not recognized in Toolbox any more...

Esteemed Contributor III


I enlisted to the community to try to find an answer to my problem in the title.

I have a few years old computer running a Core i7 860 on a asus P7P55D Deluxe MB.

Not having SATA III support I got a PCIe card with 2 SATA III ports for optimal support. Not sure about Manufacturer, but its a Marvell chip.

I installed Win 7 on my brand new Intel 330 120 GB SSD without any regard to manuals or how-tos.

Everything working wonderfully, I installed SSD Toolbox, tested all the optimize and checks in the toolbox tabs wihout a hickup.

Now after having installed the latest win patches and drivers for chipset, gfx, the SSD Toolbox does no longer recognize my ssd drive.

The drive is working wonders, speedy quick fast awesomeness, no BSODs (yet), no problems whatsoever other then that it wont enable the "optimize" and other SMART features in the toolbox.

Not sure if its a bad thing. I ran the optimizer once, but future firmware updates wont be applicable.

How can I figure out whats wrong and how can I fix it?


PS Sorry if I've posted yet another post about this, but I cant seem to find the same symptoms in other posts.

PPS Sorry if I dont use the right lingo, Im all new to SSDs

PPPS Sorry if my english is off, I'm swedish...

Message was edited by: Tobias Axelsson Fixed spelling


Esteemed Contributor III

I was probably a bit foolish not doing more research before posting.

This forum contains most answers theyre just not compiled to a "For Nubs" stickie thread.

Heres a bunch of asumptions that would be useful to have confirmed. Please correct me where needed.

I assume Windows 7 as OS.

To check the driver:

Select Device Manager -> IDE ATA/ATAPI controllers -> Standard AHCI 1.0 Serial ATA Controller(or whetever controller you might have running your SSD)

Right click and click Properties, select Driver tab, click Driver Details.

Check that msahci.sys driver is in the list.

If this is the case then TRIM is working and no action is needed.

The SSD Toolbox optimization function is not needed if above is true as the Optimize function only does garbage cleanup left when TRIM is NOT enabled.

Intel Rapid Storage was previously called Intel Matrix Storage and they are the same thing. IRS is used today.

IRS is not needed if you found the msahci.sys driver as above unless you use RAID.

If you have installed the Intel Rapid Storage manager it overrides the MS driver and SSD Toolbox Optimize IS therefore needed.

Might make this a separate post to have stickified and expanded with more anticonfusion if above is confirmed.

I guess SSD is new for many as there are quite the confusion around. Thankfully the good people of this forum know the facts and keep correcting the unknowing.

Esteemed Contributor III

The Intel IRST driver does not stop TRIM from working with SSDs. Even when used in RAID mode, single drives that are not part of a RAID volume receive the TRIM command just fine.

If your SSD is connected with your PCIe card, which likely uses a Marvell or ASMedia chipset, you don't have IRST installed on that card. IRST will only work with Intel chipsets.

Your PCIe card may have msahci on it, or the native driver for its chipset, either Marvell's or ASMedia. Your SSD on that card might be recognized by the Toolbox if you are using msahci with it, but if you are using the cards native driver, it most likely will not. I suspect that during your various updates, the driver on your PCIe card was changed from msahci to your cards native driver. That would explain why the Optimizer is not available on your PC for that SSD now.

Check Storage Controllers and IDE ATA/ATAPI Devices in Device Manager, to see the current configuration of chipsets and drivers on your PC.

Message was edited by: Robert Cook

Esteemed Contributor III

Hi and thanks for taking the time to reply!

As stated in the original post my SSD is connected to the PCIe controller that use a Marvell chip.

The driver used is a Marvell 91xx driver, and I cannot find the exact chip used anywhere. Might possibly be printed on the chip itself, must check tonight.

I read here: that a user named Parsec (You? ) in post 21 suggest using the msahci driver instead of the marvell driver. Ill try that tonight as well.

Have pics of current driver setup and benchmarks with AS, but failed to make them accessible before leaving for work today... Will post asap.

Esteemed Contributor III

I've had some time to tinker with this and I have ended up using the onboard SATA 2 controller. I get better benchmarks with Intel SATA2 controller then with any driver on the "Dexlan" produced Marvell chip.

I tried several drivers for the Marvell, first the Windows autoinstalled Marvell driver version 1.2.1014.

AS Benchmark:

I also tried msahci with almost exact result.

I later found a driver update, the Marvell

AS Benchmark:

Differs a bit bit same end result.

then I switched to the onboard Intel 5 series/3400 Chipset Family 6 SATA controller - 3B22.

This only has SATA 2 support.

AS Benchmark:

So in conclusion I stick with the onboard SATA 2.

The results aren't that good in my oppinion. SATA 2 should allow for 300 MB throughput. But perhaps its because i'm running my OS on the same drive.

Any tips?

edit: Oh I forgot. with that later Marvell driver as well as when changing to msahci.sys driver, SMART is enabled and can be seen in Intel SSD Toolbox when on the SATA3 plug-in card.

This also works when connected to the onbouard controller obviously.

Message was edited by: Tobias Axelsson added some SMART info with Marvell driver