Showing results for 
Search instead for 
Did you mean: 

Win 10 cannot do an inplace upgrade on my SSD 600P series

New Contributor II

win 10 sees my M.2 SSD 600P series as a USB flashstation with setup so i cannot do an inplace upgrade how can i fix this.


Actually Bruce, I think it may be SSD related, but not the way you think. My understanding is that NVMe support requires UEFI Boot. The SSU report indicates that Legacy Boot is being used. [Aside: It is unclear, but I get the feeling that this is a system that has been migrated multiple times, including from Windows 7 to Windows 10 (directly or eventually).] Regardless, a full reinstall of Windows 10 will be necessary. The Windows 10 installation media must be properly booted in UEFI mode and, during the installation process, all partitions on the SSD must be deleted (so the Windows 10 installer can create a proper GPT partition table).

Hope this helps,


View solution in original post


Contributor III

Hello, @Jokerdad .

Thank you for contacting the Intel Community Support.

I received your ticket involving the Intel SSD 600p Series, I will be glad to assist you.

Since this is not an Intel Hardware/Software related process, the best option would be to contact Microsoft for assistance, that way they can provide you guidance and also help you overcome any errors encountered during "in-place upgrade".

You mentioned the drive being recognized as a "USB flashstation", how is the drive recognized in Device Manager and Disk Management?

You can right-click the start menu button and then click Disk Management to see the drives and the partitions, or click Device Manager and then click Disk Drives to see the storage units recognized by your system. 

Is the 600p directly connected to the system (without enclosures, adapters, or other)?

Let me know.

Bruce C.

Intel Customer Support Technician

A Contingent Worker at Intel


my ssd is in the diskmanagement seen as a Standard NTFS diskdrive when my ssd is installed in the M.2 socket or on my PCIe card.

it was attached in a M.2 socket now i have installed it on a PCIe card.

when it was installed in the M.2 socket i had support for 2.5 hours of microsoft they took over my computer and tried the inplace upgrade that did not work,

then they deleted my antivirus and anti malware programs then they tried it again to install the inplace upgrade this did also not work,

then they used their own software to clean and repair and test the computer then they tried again to install the inplace upgrade and it stil did not work,

then they gave it up.

every time when they tried to install the inplace upgrade there was the message of: you cannot install windows on a USB flashstation with setup.

then i updated the drivers of the motherboard and the BIOS and  updated all the Intel drivers for Win 10 then i tried to install the inplace upgrade the message was there again.

then i bought the PCIe board with M.2 socket and put the ssd on this board and put it on the motherboard in the PCIe socket,

then i booted the computer and it all works fine so then i tried to install the inplace upgrade again and there was the message again.

my motherboard is an MSI Z270 SLI PLUS vesion 1.0 (MS-7A59) BIOS version: E7A59IMS.V1.A0

with kind regards

Hello, @Jokerdad.

Thank you for your reply.

We would appreciate it if you can provide us with the following information:

• The SSU logs.

1- Go to (for Windows*) and to (for Linux) download the software.

2- When finished downloading it, open it.

3- Attach the file generated by the tool in your reply.

• How is your SSD detected in your BIOS, when connected to the M.2 port, is it detected properly?

• We do not support the usage of adapters with our SSDs, and we suggest you; connect the drive directly to the motherboard M.2 port.

We will be looking forward to your reply.

Best regards,

Josh B.

Intel® Customer Support Technician

A Contingent Worker at Intel®

here is the SSU file and foto's of my BIOS


With kind regards