Showing results for 
Search instead for 
Did you mean: 

520 Series 240GB solid state Disk will not work as a boot disk

Esteemed Contributor III

I have a desktop PC with a Gigabyte motherboard type GA-P67A-UD4-B3 with a Kingston 64GB SSD as the boot drive C which has worked well without problems. I wanted to update drive C to provide more storage and I selected the Intel 240GB 520 series to use as a replacement.

My current drive C was copied to the new disk without any apparent problems, but my system would not boot from it. When the BIOS screen came up it had the top half as virtual lines and would never get pass this BIOS screen.

I copied my Kingston SSD drive C to a standard hard drive and tested that which worked fine.

I then re-copied my Kingston drive C to the new 520 SSD again just in case there was a problem with the copy, but it still would not boot using the new 520 series SSD.

So, I went out and purchased a new large Kingston SSD drive which worked without problems.

Conclusion is that my new 520 Series SSD cannot be used as a boot disk, well not with a Gigabyte motherboard anyway, but works perfectly as a non boot disk.

Am I missing something here or is there some issue using these SSD's with certain motherboards which certainly was not mentioned when I purchased it ?


Esteemed Contributor III

The problem you had with the BIOS screen is strange, since nothing is being read from a drive for the BIOS to be displayed. You should be able to get into the BIOS without any drives attached. The BIOS does read drives to the extent they are listed and tested to a degree. The corrupted BIOS display seems to be a clue that something is not right, indirectly related to the 520, such as a power connection.

Have you cleared the CMOS/BIOS at any time when connecting your new drives? Was the 520 formatted when you copied your OS to it?

It's premature to decide IMO, that a 520 is not useable as a boot drive on your specific mother board. I've used and currently use 520's as boot drives on several different boards, but not on a Gigabyte board. If that was a general issue with Gigabyte boards, it would be well known by now.

Was your 520 connected to the same SATA port as your Kingston drives? Your board has a Marvell 9128 SATA III interface, which generally do not work as well as the Intel SATA interface. Where were your SSD connected during the OS cloning process?

What OS are you using? What software did you use to copy your OS?