Showing results for 
Search instead for 
Did you mean: 

How do I prevent further damage after flashing the firmware?

Esteemed Contributor III


I flashed the new firmware to my 80GB G2 drive in AHCI mode. Did the reboot after Windows 7 Final (x64) installed new driver (Intel Matrix Storage Manager is present). Installed SSD Toolbox and ran optimization once. And, no, I did not get the error so far. Everything still works fine after a few reboots.

Now, here is my question:

Since the bug seems to be very common, is there a special action which is causing the error - such as changing some special BIOS settings - which I should avoid? E.g., I suspect that the reason why everything still works is that I had installed the IMSM before, which does not pass TRIM to the drive. Thus, the drive didn't get corrupted so far simply because no TRIM commands have yet been passed to it by the Microsoft driver. However, the SSD Toolbox optimization feature seems to work correctly, as I ran it and the drive is still alive.

Before I heard about the severe problems associated with the recent firmware update, I considered uninstalling IMSM and replacing the Intel drivers with the Microsoft alternatives in order to enable TRIM. However, I now have a feeling that this might turn out to be a quite bad idea.

Is there any statement by Intel Officials about what to do if you flashed the erraneous firmware but your drive is still working? Going back to the earlier firmware is not an option, as the firmware flashing tool rejects doing so. I could live with the way it works now, but it would be an interesting information whether I can safely replace the IMSM driver with the Microsoft one without a risk of bricking the drive and losing all data stored on it as well.

BTW, I am severely disappointed in Intel right now, even though I am not affected by the bug (yet?). I spent 300 USD for this drive not because of the performance (which is great but not worth the additional cost compared to the similarly well performing Indilinx drives), but rather because I had more confidence in Intel regarding data integrity, safety and testing prior to releasing the hardware. The ATA password bug was one thing I could live with (well, we all make mistakes, and ATA passwords are not a commonly used feature), but after many months with TRIM-enabled firmwares already being available from the competitors, Intel should have had the time to test this update thoroughly.


Esteemed Contributor III

My specs:

- Windows 7 x64 Ultimate (Final Version)

- AHCI mode turned on in BIOS (also while updating the firmware)

- Intel Matrix Storage Manager installed

- Asus P5Q mainboard, Intel P45 chipset, 8 GB RAM, Intel Core 2 Duo E8400 (3 Ghz)

- Intel G2 Postville 34nm X25-M 80 GB SSD (also updated before with the firmware fixing the ATA password bug)

- Intel SSD Toolbox installed, did Optimization run, SMART check still returns OK

- BIOS does not report any errors, however the amount of cumulative data written (according to SMART) seems quite high to me (approx. 3 TB after 2 months of usage)

- about 20 GB free on the drive

Intel is sorry about the frustration this is causing. If your drive is working properly with your current system settings, there is a good possibility you will not have any further problems. Please do not change your driver settings at this time until Intel gives further guidance.

Best Regards,

Brady - Intel NAND Solutions Group

Esteemed Contributor III

Thanks for your reply. Looks like I'll have to wait for a fixed firmware release before trying to replace the Matrix Storage Manager drivers with the Microsoft ones.

Esteemed Contributor III

Just wanted to share my experience too, I have an Intel 80gb G2 running on an HP EliteBook 6930p laptop. I have updated the firmware yesterday (switching to IDE mode) and did a fresh install of Win7 (on AHCI now), only to find after a reboot that I had a non-system disk error.

I ran HDDErase in IDE mode and then reverted back to AHCI once again, freshly installed Win7 x64 and everything seems to be going smoothly so far. I am running the native Win7 drivers and only installed the SSD Toolbox. Ran the tool a couple times already and did several reboots with no apparent issues.

The only thing odd, as derkurt mentioned also, is the amount of data written reported by SMART, 1.5TB for less than a month of usage.