Showing results for 
Search instead for 
Did you mean: 

BSOD with Intel 520 Series 240Gb on Alienware M17xR3 Laptop. Any Suggestions?

Esteemed Contributor III

I have an Alienware M17xR3 Sandy Bridge laptop w/ Core i7-2820QM, 16Gb RAM, Radeon 6870M w/Intel 3000 graphics, and 2 SATA 3 HDD ports (not RAID), BIOS setting for ACHI , running Windows 7 Pro. Using current Toolbox v3.03 and tuned accordingly.

Until last month, it had 2-320 Series SSD's (160Gb) and they worked perfectly. I just ran out of space and upgraded to the new 520 series. Two of them. Shortly after I installed the new drives I started getting BSOD's every few hours or so. Could not fix, so I reinstalled Windows fresh. Not a fix. Called Intel and was shown how to deep format the drive during the Win 7 install pgm. Did it. Nice, but not a fix. Returned the drive to the store. New drive arrives, a clean install, and the BSOD returns.

I reinstalled the 320 Series SSD and a fresh install of windows. Works perfect.

I am hoping someone has a suggestion how to fix this. I can not return these 2 new 240Gb drives. I need to make them work. I am a big intel fan. Your thoughts. Thanks.


New Contributor III
New Contributor III

I am an SSD tech at Intel, and hoping I can help you try to figure out your problem? I'm not clear if you are using these 2 drives as RAID config, or just 2 drives in the system. If not RAID, then I'm assuming you have OS and apps loaded on one drive, and second drive is for backup and other data. Can you remove one drive and problem still happens? What storage driver are you using? If RST, can you go into RST GUI and check to see what SATA speed the drives are negotiating at? Does the BSOD seem to happen during a common event on the OS(like virus scan running or game launch or ...) or is BSOD completely random?

Esteemed Contributor III


Thanks for your interest. Here are the answers to your questions:

No, I am not using the drives in RAID. BIOS is set for ACHI and only one drive is installed. initially I just assumed all was well and installed Win 7 Pro on the C drive. Later I installed the secondary drive just to store music for iTunes. Worked OK for a while, then BSOD. Removing the second drive had no effect. I reinstalled Win 7 again using just 1 drive. BSOD.

Storage driver is the current driver from the Intel website, as is the toolbox as of a few weeks ago. The RST GUI indicates the drive speed is 3 Gb/s. Never went to 6. I did not install a speed test because it seemed quicker than my 320 Series drives and I was happy with that. Besides, the BSOD issue kept happening.

The BSOD happened randomly it seems. I do not play games on this laptop. A BSOD often happened often while using IE9 and was just reading. It would also happen when I ran the Full Diagnostic Scan in the Intel Toolbox. Actually it would fail only during the Data Integrity part of the test (second test).

That's about all I know about this config. If you think you have an answer, I am still interested.

Thanks again...


This failure is odd. Other high level question: have you checked with Alienware to see if they may have some BIOS problem with SATA 6Gbps? Because the drives are not registering as SATA 6Gbps in RST GUI, makes me think there may be BIOS issue. Another thing to check is if you know Windows System Log, go in and see if you are getting any errors because of iastor. (iastor is RST driver service name.) If you can see iastor error events happening around BSOD time, then description of those errors may help isolate this. If you don't know System Log, I can describe how to do that. Another thing to try if still available - although it may take some effort - is to put back in the 320 drives and see if system still works with those drives.

Esteemed Contributor III

The BIOS was the first thing checked after the normal stuff. The BIOS is V-10, which is current as of a week ago. There are reports some of the M17xR3 Alienware laptop not seeing 6 Gb/s performance. Nice to have, but not a deal breaker for me. I would keep the 520's if that's all it was.

I also checked the Windows System log and action center with nothing to report. Just a message that said the system had to reboot.

I reinstalled the 320 Series SSD last Friday. I installed the original 160Gb as the primary drive using a fresh deep format install Win 7 Pro. I also purchased a new 300Gb 320 Series for the music files. 5 days now and everything is running perfectly.

As I recall, the 320 Series uses the Intel Controller. 520 Series does not. I am guessing that that is the problem. Dell uses the Samsung 830 Series drives in the stock Alienware SSD configuration. I wish they would use the Intel drives instead. One interesting thing. The 520 Series scored 1 point higher than the 320 Series in the Windows Experience Index. It is a faster drive.

Even though my laptop is under warranty, Dell will not support non standard parts. Reasonable thinking. I did check their forums, without success.

I have this feeling that there will not be a fix anytime soon for me. I was told ASUS makes this Sandy Bridge motherboard for Dell/Alienware. It may not be economic for Intel to configure this drive for such a limited application as this. I understand that. Hopefully, someday they will standardize common upgrades like SSD's. Thank you for your time and effort. I appreciate it.