Showing results for 
Search instead for 
Did you mean: 

X25-M G1 - Shows as 8MB 'Intel SSD Bootloader'

New Contributor

I have an old X25-M G1 which was working perfectly on firmware version 8610 (which it came with), however I attempted to run the SSD firmware update utility to 8820 and the process completed but upon reboot the device now shows as an 8MB drive with the model name: 'Intel SSD Bootloader'

Through some searching it sounded like this was not unheard of, however I couldn't find any mention of this happening with a firmware update, only weird rare power issues.

Searches suggested trying ata security (secure) erases, dco resets etc but the drive times out with any command given by hdparm, example:

ata14.00: exception Emask 0x0 SAct 0x0 SErr 0x0 action 0x6 frozen

ata14.00: failed command: SECURITY ERASE PREPARE

ata14.00: cmd f3/00:00:00:00:00/00:00:00:00:00/40 tag 27

res 40/00:00:00:00:00/00:00:00:00:00/00 Emask 0x4 (timeout)

ata14.00: status: { DRDY }

ata14: hard resetting link

ata14: SATA link up 3.0 Gbps (SStatus 123 SControl 330)

ata14.00: configured for UDMA/100

ata14: EH complete

This is the output of hdparm -I:

ATA device, with non-removable media

Model Number: Intel SSD Bootloader

Serial Number:

Firmware Revision: BT16B030

Transport: Serial, ATA8-AST, SATA 1.0a, SATA II Extensions, SATA Rev 2.5, SATA Rev 2.6


Used: ATA/ATAPI-7 T13 1532D revision 1

Supported: 7 6 5 4


Logical max current

cylinders 16383 16383

heads 16 16

sectors/track 63 63


CHS current addressable sectors: 16514064

LBA user addressable sectors: 16384

Logical/Physical Sector size: 512 bytes

device size with M = 1024*1024: 8063 MBytes

device size with M = 1000*1000: 8455 MBytes (8 GB)

cache/buffer size = unknown


LBA, IORDY(can be disabled)

Standby timer values: spec'd by Standard, no device specific minimum

R/W multiple sector transfer: Max = 1 Current = 1

DMA: mdma0 mdma1 mdma2 udma0 udma1 udma2 udma3 udma4 *udma5

Cycle time: min=120ns recommended=120ns

PIO: pio0 pio1 pio2 pio3 pio4

Cycle time: no flow control=120ns IORDY flow control=120ns


Enabled Supported:

* Power Management feature set

* Mandatory FLUSH_CACHE

* Gen1 signaling speed (1.5Gb/s)

* Gen2 signaling speed (3.0Gb/s)


Master password revision code = 65534


Checksum: correct

I even tried extracting the raw binary blob of firmware version 8820 in the firmware update iso to try pass to hdparm --fwdownload but it failed with "DOWNLOAD_MICROCODE: not supported by device"

The firmware update tool now says it's running the latest firmware and won't do anything, the intel ssd toolbox on windows reports it as an 'X-25M 8MB' and it reports the firmware up to date and fails to secure erase it.

My guess is it seems to be stuck in some weird state which the firmware update tool left it in, but I really have no idea.

Has anyone come across these before and had any success resurrecting the drive or any tips I can try before binning this old drive?


Thanks for the suggestion Joe, but I've tried secure erasing the drive but to no avail. As above from the hdparm output the ssd does not show any security parameters (frozen/locked/enabled/supported/etc), and replugging like you normally would for a frozen drive doesn't change this. Neither does setting the password, even though it appears to succeed the status doesn't show, nor does any logging report a success/fail.

I've also tried just straight up issuing the secure erase command (with passwords, even though it doesn't look like they set anyway, and without - eg NULL) and the commands just timeout as per the logs above.

Valued Contributor II

You may want to check if the drive is still in warranty and contact Intel support for replacement.