Showing results for 
Search instead for 
Did you mean: 

Terrible 4K transfer and access times with X25-M

Esteemed Contributor III

Hi all,

I have some performance issues that I can't seem to straigthen out.

These screenshots should give you an idea what I mean:

The SSD is connected to a GigaByte GA-770TA-UD3 through the AMD SB710 host (the Marvell 9128 controller performs even worse).

Latest BIOS update, AHCI enabled before installing Windows 7 Ultimate 64 bit. Used all the latest drivers.

What I've tried so far:

  1. Used the latest dedicated drivers for the SATA chipset instead of the generic Microsoft drivers that come with Windows 7
  2. Used the latest Intel SSD Toolbox to check the firmware and use the optimizer
  3. Checked if TRIM is enabled on the drive
  4. Prefetch, defrag,... is enabled or disabled as it should for the SSD
  5. Used HDDErase to completely clean the drive with the internal "enhanced" command
  6. Spend lots of time reading up on the subject, but can't figure out what's wrong
  7. I've looked into the RST drivers, but as far as I understand these are only for Intel chipset motherboards, correct?
  8. Ran the benchmark several times, and even though of course the exact figures change a bit, they're consistent...

Any ideas on where to go from here? I think I have done all the obvious things, but might have missed something?

Any help would be much appreciated.




Esteemed Contributor III

Have you tried running these benchmarks in Safe Mode?

Esteemed Contributor III

Hi Mutex,

These benchmarks weren't don't in Safe Mode, but I've tried it now.

Even the average of two benchmark runs is even worse than what I get outside of Safe Mode, with both access times around 0,63 ms...

Esteemed Contributor III

My first X-25 M SSD is 2.5 years old, and I've never seen AS SSD results that were that odd. The 4K and Access Time results are quite poor, as you know, while the sequential results are normal, and the 4k-64Thrd speed is a little low.

Your screenshot shows msachi as the driver. You can't use the Intel IRST driver on an AMD chipset.

The Toolbox works fine for you with the AMD SATA chipset, and the Optimizer too as you said, correct? What does the Toolbox show for the drives health? How do the SMART attributes look in the Toolbox?

Have you had this SSD for a while, or is it new in that PC? Are you using any encryption software? How much free space does the drive have?

AMD tends to have quite a few options and settings for their SATA ports, which I am not familiar with, but checking them could help.

If your results were similar in Safe mode, that indicates you likely don't have a process that is slowing down the results.

IMO, using HDDErase to perform a Secure Erase would not be my first choice. If you chose anything that actually wrote zeros or ones to the SSD, that would not be good, but I would think that would affect your other results. I've read that the enhanced option is not good for use with SSDs, but not certain about that. Did you try the Toolbox Secure Erase?

Did you try a different cable, or moving the connection to one of the first SATA ports? CPU power saving options can affect benchmark results, but I've never seen 4K results that low even in that case.

Esteemed Contributor III

Hi Parsec,

The SSD Toolbox works without any problems, the process takes about a second on the disk (but I have clicked that button a lot the last few days). The SSD is about two years old I think. No idea if the results where any better in the beginning or not. I bought it when I made my current PC, so couldn't compare it to the system without an SSD. I do remember not being too impressed by the bootup times and such things. Should have ran some benchmarks at the time...

I didn't try the toolbox Secure Erase as this doesn't work when the SSD is the one with you OS on.

I don't have a second desktop here right now so can't really try it out either without doing a complete new install on a harddisk. If you think it's really worth a shot I could look in to it.

I haven't found too many options for the SATA ports (I suppose you mean in the BIOS, right?), but have tried the combinations and benchmarked the drive every time. The current setup is the fastest.

Just tried another cable and moving it to the first SATA port, but to no avail.

Where should I start looking regarding the CPU Power saving options? I haven't overclocked anything.

I'll take a look around what I can find about cpu power saving options and post if I find anything.