Showing results for 
Search instead for 
Did you mean: 

SSD Locked During Secure Erase

Esteemed Contributor III

I was doing a secure erase on an intel 320 ssd. The system I had it connected to had a newer intel rst driver on it. Which I found out to be the cause afterwords. But during the secure erase the system reset the data connection to the drive causing it to be locked. The system can still see the drive just can't do anything with it. Is there anything I can do myself or pretty much SOL?

I tried doing a secure erase with HDDerase but it asks for a password which I do not know.

I tried parted magic with default settings and not connecting the ssd until it booted. It saw the ssd but neither the enhanced secure erase or the non enhanced secure erase changed anything they both reported as completed but the drive is still locked.

The drive is not available to windows only to the rst program it will list the drive but intel ssd toolbox can't see it either to do anything.

Tried the system passwords for the system the ssd was originally part of and for the system it was connected to when I tried to secure erase it from hdderase v3.3 neither worked.

Is there a master password or anything I can try?

Thank you for any help


Esteemed Contributor III

That may be a difficult problem for you. You may need to contact Intel Support directly for some assistance, start here:

Why do you say it is the IRST driver that is causing the problem?

Intel plays more by the rules about drive security than some other manufactures. That is, they follow the rules about how a drive should react when things like a secure erase (SE) are attempted on a drive. Other manufactures just allow anyone to SE a drive, as long as you have their program used to SE. Anyone can SE your SSD with the program and a few clicks. But, this can cause headaches if you don't SE an Intel SSD carefully.

You are experiencing the Security Freeze lock that your 320 supports, as other Intel SSDs do. If you had used the SSD Toolbox first, among other things you would need to power cycle the SSD during the SE process to unlock the SSD. At this point, you may have locked the drive down even worse. You could try power cycling that SSD while the PC is running. That is, quickly remove and reconnect the power cable to the SSD while the PC is running. If you are lucky, it may unlock.

I can't recall if a new, raw Intel SSD can be seen by the Toolbox. If not, that SSD sound like it has had its volume deleted, and is like a new, raw drive, and Windows cannot see it, yet. Did you try going into Windows Disk Management (Windows 7 I presume?) and see if you can initialize that SSD? If you can, then you can take it from there.

Esteemed Contributor III

The IRST driver that I had caused the issue of it becoming disconnected while doing a secure erase. I know this because I had a few other intel ssds that I secure erased and they would get to about 40% and then say they failed. I removed the driver from the system and put on a different one and the issue went away.

If I locked it down even worse as you say then that is from me trying to unlock it. I did use the intel ssd toolbox first and I tried power cycling the drive while it was connected to the system still no change.

The drive is only visible to the IRST program as I mentioned not to the toolbox program or windows itself.

Esteemed Contributor III

I'm not exactly sure what happened to your SSD, but it sure needs a SE now. I have had so much trouble with the Toolbox SE function, I can never get past the Freeze Lock, no chance. I was only able to get one G2 SSD to SE. I was wondering about third party SE programs, and the Freeze Lock thing on Intel SSDs, so I never tried it. How did I know it would not work well.

I would not wait for more help here, contact support right away, you may even end up RMA'ing your SSD.

Esteemed Contributor III

I recently hit the same problem, with a slowy dying Intel 320, which was RMAed. Before sending it back I needed it to be Secure Erased but the Intel SSD Toolbox 3.0.2 wouldnt let me ... Security Freeze Lock. The SSD Toolbox even froze the PC too. WTF! No disconnecting from power ever succeded.

HDTune Pro 500 did the job of filling it up with Zeroes, including verification, on the first try.