Showing results for 
Search instead for 
Did you mean: 

Intel SSD 530 Series works fine but can't install windows on it

New Contributor

I've just purchased Intel SSD 530 (120Gb). Like the title says, I can't install windows 7/8 on this SSD. I have tried to install it in both IDE and AHCI.

Windows installation just won't see my drive. I have tried on 2 mobos, a Gigabyte 990FXA-UD3 and a AsRock 970 Extreme3. Both mobos have the latest firmware, the ssd has the latest firmware. Also I have another 2 SSDs that work just fine. I can see the SSD in BIOS, but not in the windows installation.

I can see the SSD in windows, I can copy files on it. It shows that everything is fine in SMART.

I'm not a PC beginner. I like to belive that I'm a pro when it comes to PCs so please don't treat me like a kid .error failure firmware


Valued Contributor II

Perhaps loading the (F6) SATA controller driver during Windows* installation may help. Otherwise, I would suggest testing the drive in a system with Intel® Chipset if possible.

I'm sorry, but I only have AMD platforms available for the time being. I have tried to use the SATA drivers but to no avail.

Valued Contributor II

I apologize; it seems to be a compatibility issue.

What compatibility issue ? It's not like i'm puting an intel cpu on an amd motherboard. It's a storage device. Even my tv (a very old tv) and my car stereo recognizes my kingston ssd as a simple storage device.

By the way. I've managed to find myself a notebook with an intel chipset and put the intel 530 ssd in it to try and install windows. I get the same thing.

I'm guessing it's a firmware problem.