Showing results for 
Search instead for 
Did you mean: 

Firmware Update Tool won't find my 60GB 520's

New Contributor

Firmware Update Tool v1.93

2 x EKCV315402D5060GN - 60GB 520 Series - FW:400i

Tried by plugging into SATA ports of a number of M/Boards, including Intel DQ77MK and DH67GD and DG45ID.

In each case, I tried both AHCI and IDE modes in the BIOS.

In each case, the M/Board can identify the drives no problems, and I can use the drives with the O/S.

However, the firmware update tool says there are no Intel SSD attached, and doesn't allow me to do anything.


Valued Contributor II

Thank you for posting,

I understand you are trying to update the firmware on the Intel® SSD 520 Series.

Please note the Intel® SSD 520 Series already has the latest firmware; therefore, there is no need to update it. You may verify the firmware update is available for other models using the following link (and the first models list):

You mentioned the drives are properly recognized by the motherboard and operating system. Just in order to make sure the drives are working correctly you may run a diagnostic test with the Intel® SSD Toolbox: