Showing results for 
Search instead for 
Did you mean: 

Acer A0751h/DC S3500 SSD : BIOS does not identify ssd

New Contributor

Hi tech folks!

I wanted to upgrade my old netbook Acer A0751h (Intel Atom Z520, ) with SSD DC S3500. But BIOS does not identify the model of the disk and the "operating system is not found" message is shown after loader is started. I have installed into this SSD Ubuntu 14.04.1 successfully and have been able to boot with live usb-stick and mount this ssd (so ssd works correctly). Also this ssd disk is correctly shown in other machines with more recent BIOS and hardware.

What can cause this behavior? Can it be fixed anyhow?

Thank you for your help!




Valued Contributor

Hello alexndr-frolov,

Have you tried to update the BIOS firmware on this PC and then try the SSD to see if it is recognized? If the SSD is working fine on other machines with most recent BIOS and hardware you may want to contact Acer for further assistance on compatibility questions. The link bellow will lead you to Acer* Support. How do I update the BIOS on my Acer Aspire One AO751h netbook?

They can also support you via chat. Please access the link below. Live Chat

Let us know if this information helped you.

New Contributor

Hi aleki_intel,

I have updated BIOS on this netbook to the most recent version 32.12, still I have the same result. As for Acer support then I have the following message:

Our records indicate the serial number you have entered is no longer eligible for warranty support.

If you feel this information is incorrect, please scan and submit a copy of your Proof of Purchase.


that is my netbook is out-of-support 🙂 That is why I need to struggle with it myself.


Valued Contributor

Hello Alex,

We understand your frustration with Acer. Here are some recommendations that may help you.

Please check if the SATA controllers of your computer is set to AHCI (SATA), if does not work, you can switch the mode as some earlier adapters may work better in IDE mode.

Please make sure the drive is properly seated in the slot.

If this the first time you are using this SSD in this computer, you will need to install an operating system.

New Contributor

We are having a similar issue w/ the 240GB Intel SSD (SSDSC2BW240A401) in a LOOP L5 AIO (Intel) w/ a DH61AG mother board. When you first put the SSD in the unit, it boots up fine. However if you shutdown/restart the unit it gives the error "No Bootable Device Found". If you unplug the unit and reconnect the power, it will boot fine. for your Laptop you could try removing the Battery and AC adapter, wait 30 sec and reconnect the AC adapter and try booting to see if that works.