Showing results for 
Search instead for 
Did you mean: 

X18-M problems with desktops

Esteemed Contributor III

This is a heads-up for ppl considering purchasing X18-Ms for their desktops. A few months ago, I purchased an X18-M (latest firmware) for a SFF build: GF9300-D-E m/b and picoPSU-150-xt. I purchased a micro-SATA adapter since desktops typically don't have a native micro-SATA port. For my purposes, I needed an LP4 (or 4 pin molex) to SATA-Power converter, since my PSU doesn't have SATA-power with a 3.3v rail (the orange wire). Therefore, the micro-SATA adapter I purchased converts the 12/5v from the SATA-Power to 5/3.3v for the micro-SATA connector (it looks like the Startech model). Now for the problems.

SSD1: On initial install of the SSD into the GF9300, the BIOS happily detects the SSD in AHCI. I happen to be booting off a USB flash device into WinPE3, where diskpart also detects the device. The moment I tried to format the device, it disappeared from diskpart and from the BIOS. To verify that I bricked the drive, I tried it on a D945GTP m/b and sure enough IDE and AHCI dies with it. After a brief conversation with Intel support, I RMA the part and get another one. I also replaced my micro-SATA adapter, just in case.

SSD2: Upgraded BIOS (GF9300, D945GTP). Again on the GF9300, BIOS recognizes the device in AHCI, boot to WinPE3 x64, and try installing Win7x64 Ultimate. Installation dies with 0x80070002 and the device is bricked. Try on D945GTP with same result. Short call to Intel support, RMA the part and retry.

SSD3: Switch to SATA/IDE mode. Again on the GF9300, BIOS recognizes the device in IDE, boot to WinPE3x86, and try installing Win7x86 Ultimate. Installation dies again with 0x80070002 and the device is bricked. Again, confirmed on D945GTP. Longer call with Intel support. Full range of system details, including micro-SATA adapter. RMA the part and retry.

SSD4: On the D945GTP, BIOS recognizes the device in IDE, boot to WinPE3x86 and try installing Win7x86 Ultimate. Installation dies with 0x80070002. Confirm with Intel support LP4-SATA Power, with micro-SATA. Intel engineering tries similar configuration with no error. Intel takes the position that it doesn't qualify X18-M in systems without a native micro-SATA port (e.g. netbooks). Support tech says Intel marketing does not recommend installation of X18-M in desktop systems as they cannot qualify micro-SATA adapters. He also states that X18-M have a very good record in the field. Support tech suggests I sell the drive.

SSD5: I'm tempted to purchase a completely different micro-SATA adapter and see what happens. I did check voltages and sure enough 3.3v and 5v pins looked good on my adapter. I'm suspicious of Intel concluding the connector is at fault, since it boots up okay and others have had similar issues. At first I thought the SATA controller was the issue, but the D945GTP took that out of the equation. Unless someone has a workable solution, or can convince me otherwise, I'm going to abandon the X18-M altogether.

I've wasted about 4 months on this issue alone.

Early adopters be careful.