Showing results for 
Search instead for 
Did you mean: 

Win7 won't install on X25-M G2

Esteemed Contributor III

Windows 7 Ultimate x64 appears to go completely through its installation, but on it's final reboot, I see the "starting windows" splash screen, then nothing. Black screen, sometimes with the mouse pointer and nothing else, left it running for ~25 minutes with no change. Same results on subsequent reboots.

  • Drive is: SSDSA2M080G2XXX, OEM version from NewEgg. Problem occurs on shipped firmware, as well as the latest 02HD version (yes, new firmware flashed successfully).
  • Intel DP45SG mobo, latest firmware. Problem occurs with BIOS set to AHCI, RAID, IDE. Didn't try IDE Legacy...
  • Intel Q9300 C2Q at stock 2.5GHz
  • 4 GB (2x2GB) G.Skill DDR3 RAM, stock voltage. Yes, the mobo is finicky with RAM, but this ram has worked great for a year now.
  • MSI GTX260 896MB, 192 Core version
  • Tried installing from Win 7 x64 DVD, then tried Win 7 x86 DVD; same result.

Trying to start in Safe Mode gives "can't complete installation in safe mode, installation will continue after reboot" error message. Running windows repair tool from install DVD says "no issues detected" with the Windows 7 installation that's detected (~14GB I think) on the SSD. 1 DVD drive, no other hard drives plugged in during install. SATA cable plugged into the SATA0 slot.

I built this rig a year ago, and it's successfully run Vista and 7 x64 with no real issues. In fact, I plugged my 2x500GB drives in RAID0 back in, and I'm typing this from the computer in question right now.

Would really like to avoid an RMA if this is something I can fix. Thanks for any and all advice!!!



Esteemed Contributor III

I'm pretty sure I came across this issue when I upgraded to Win 7 on my 80GB G1 drive. I couldn't get Windows 7 to boot after install when set to RAID mode, and if I set it to IDE or AHCI it would just BSOD because it had the RAID storage drivers. If I installed with the controller set to IDE or AHCI, everything was fine when booting to Windows except I needed it set to RAID to access my 2TB storage array.

Ultimately, I believe the solution for me was this:

  • Disconnect all other drives leaving only your SSD connected where you intend to install the OS.
  • Set controller to RAID mode.
  • Boot from Win7 install DVD/media.
  • Delete any existing volume from prior format/install.
  • Format drive and create new volume. *NEXT STEP IS KEY*
  • The new install should have created TWO PARTITIONS: a 100MB System Partition and the rest for your new OS volume.
  • Install OS normally after that, boot up to make sure everything is in order, then reconnect the rest of your drives.

The real key for me was the 100MB System Partition was not being created when other drives were connected. Personally I think this is a bug with Win 7's installer/bootloader that slipped through the cracks, but its also a by-product of Intel's horribly convoluted ICH southbridge storage mode settings and driver dependencies. Also, the 100MB System Partition isn't needed when I loaded a Vista image and did an in-place upgrade to Win 7 from that. It was only a requirement for new installs in Win 7 with the ICH10R set to RAID.