Showing results for 
Search instead for 
Did you mean: 

W7 detect my SSD as a SCSI disk device. How to change it to ATA device?

Esteemed Contributor III

My configuration:

OS: W7 x64 Ult

MB: Gigabyte EX58-UD3R

SSD X25-M 80GB G2 plugged on the GSATA 2 connector of MB

What I tried:

  1. In bios setup: switch "Diseable" in AHCI mode => boot stop at DMI detection
  2. On motherboard move SSD from GSata 2 (GigabyteSATA) connector to Sata 2 connector (ICHR10) => Message: "bootmgr is missing
    1. To see what Crystaldiskinfo could say about my SSD => CrystaldiskInfo don't list my SSD!
    6 REPLIES 6

    Contributor III

    You should connect the Intel SSD to the first Intel SATA port and not to any GIGABYTE (=JMicron) SATA port. After having done that, you should enter the BIOS and set the Intel SATA Controllers to "AHCI" Mode.

    If you still get the message "bootmgr is missing", just boot off the Win7 x64 DVD or USB Stick and let Windows Setup repair the MBR.

    Esteemed Contributor III

    Thank you Fernando for your answer. I already tried to check AHCI in bios setup but the option "automatic repair for boot issue" doesn't repair succesfully the "bootmgr is missing" problem, so I'll try again with dos fixmbr command

    Esteemed Contributor III

    Hello. See if the information in the following thread helps. I have an EVGA 790i mobo, and the solution was to change from the NVIDIA controller back to the "Standard" controller as in the thread below. Then my drive is seen by the tool.

    /message/78383# 78383

    Best wishes/jim

    Esteemed Contributor III

    Now, all is ok for my SSD . And I complete the Fernando answer by reporting that the problem of restarting after check AHCI in bios setup is caused by a Windows installation with IDE driver instead of AHCI driver. But the very simple solution is given by Microsoft Support for Vista as for Win7 here:


    for french people like me . Big thanks also to this complet FAQ about Intel SSD's (in Fr) at: bas bas