Showing results for 
Search instead for 
Did you mean: 

Update 320 Firmware (v1.9) failed with OSX Lion 10.7.1 installed on SSD

Esteemed Contributor III


booting the recent firmware upgrade (8/17/2011) from CDROM on my IMAC 7,1 with an internal intel 320 SSD failed to find the SSD in my mac. So freedos is alredy running, but the firmware upgrade tool doesn't find any SSD (I'm running Lion 10.7.1.)

The firmware update worked last time (2 months ago, running snow leopard) with the older BootCD/Firmware Upgrade Tool, so the 'only' thing that has changed was the upgrade from snow leopard to lion .... ups ....

Any ideas? Encryption of the file system is disabled, when encryption was enabled the cdrom didn't boot ....

Many thanks!



Esteemed Contributor III

To be more precise:

iMac 7,1 has a Intel ICH8-M AHCI chipset, running AHCI Version 1.10 (i think so, since system report says this)

My 320 SSD says:

Modell: INTEL SSDSA2CW300G3 Version: 4PC10302

Does an Installation of windows (via bootcamp) or 'The rEFIt Project' help?

Any ideas?

Many thanks in advance.


Esteemed Contributor III

I must chine in and report with annoyance that I can't upgrade the 320 firmware 1.9 either on a MacBook 4.1 (ICH 8M controller) and a 150GB SSD320 in the laptop's internal bay. FreeDOS starts but the firmware update utility claims that the SSD is not installed or has been disabled.

The SSD however IS functional and boots OS X (Snow Leopard) without problems. Also, I was able to upgrade firmware previously without problems.

Anyone from Intel tried upgrading these drives in Macs?