Showing results for 
Search instead for 
Did you mean: 

The driver detected a controller error on \ Device \ HardDisk0 \ DR0.

Esteemed Contributor III


Serienummer.CVP0952000R7080GNFirmware: 2CV102HD

Install win 7 pro 64 bit on a intel x25-m SSD on asus p5e3 motherboard BIOS:1503

install Intel(R) Chipset Software Installation Utility V9.1.1.1019intel matrix storage controller v. (from asus site)install Marvell 6121 SATA Driver V1.2.0.69 for 32/64bit Windows7.(from asus site)when i try to install from DVD drive or try to copy from other HD (intern or usb) the PC freezes periodicallyand in Event Viewer under system I see a dozen errors :The driver detected a controller error on \ Device \ HardDisk0 \ DR0.(sorry it is danish)Lognavn: SystemKilde: DiskDato: 31-01-2010 16:44:40Hændelses-id: 11Opgavekategori:IngenNiveau: FejlNøgleord: KlassiskBruger: I/TComputer: seje-PcBeskrivelse:Driveren detekterede en controllerfejl på \Device\Harddisk0\DR0.Hændelses-Xml:"> 11 2 0 0x80000000000000 4726 System seje-Pc \Device\Harddisk0\DR0 0400800001000000000000000B0004C00301000000000000000000000000000000000000000000007A3A000000000000FFFFFFFF07000000580000050000000004200A128C022040006E00003C00000000000A000000000068BA5E0780FAFFFF000000000000000060B75E0780FAFFFF00000000000000002084B704000000002A0004B7842000003700000000000000000000000000000000000000000000000000000000000000

and when i start intel matrix storage controller i can see that my SDD i now only generation 1.

after reboot it is back to normal (gen2) and working fine. copy between partitions on the SSD givs no problem.if i start win 7 pro 64 bit on my seagate HD (the other HD) it works fine copy or install to the SSD works fine...any suggestions on what is wrong?

Esteemed Contributor III

NO real pc wizards here... Fernando.. maybe

hmm here are some more:

Install win 7 pro 64 bit on a intel x25-m 80gb gen2 SSD(Firmware: 2CV102HD)

on my asus p5e3 motherboard(bios 1503)with intel_msm_8.9.4.1004-full( drivers (the 64bit loaded under the installation) install INF Update Utility Ver: then msm_8.9.4.1004 and its working fine.install a couple of games and its runing nice ( 264Mb/s read in crystaldiskmark2.2) then...

I plug in my net cable and Windows prompt me to select the type of Networkonce i select Home Network, (Windows 7 will start applying the necessary settings for my new network) i register windows 7 no problem but after ca 10 min...

i got a dozen errors in Event Viewer under system:The driver detected a controller error on \ Device \ HardDisk0 \ DR0.and the PC freezes periodically....(with every "freeze" a new error) dont have to do any thing on it...In Matrix Storage Manager im back to generation 1...still same drivers under my controller ( and now 84 Mb/s read in crystaldiskmark2.2)after reboot im back to generation 2 in Matrix Storage Manager,but just for 10 min or so then same problem.... any idea what wrong? thanks in advance

Esteemed Contributor III

I had the same error. I think it is due to a chipset bug or bad drivers. Let me explain:

I have Windows 7 64 bits on ASUS P5B-VM motherboard that has ICH8 with 4 SATA ports and one JMicron JMB363 controller with 2 SATA ports.

I had X25-M G2 80GB connected to SATA1 and Seagate ST3500418AS connected to SATA2 (both on ICH8) all with Microsoft drivers. This worked without any problem for a month.

Then, one day I connected another Seagate ST3500320AS to SATA3 (next free port of ICH8) and I started to get freezes and "controller error on \ Device \ HardDisk0 \ DR0".

Only solution that worked for me: I removed Seagate ST3500320AS from port of ICH8 and connected it to JMicron JMB363 controller.

No one single error from that day!


Esteemed Contributor III

Made a clean install with the drivers from Here

same problem BUT!!!

found that is is when ill disable my netcard the problems starts.....

dont no why but win 7 dont like that.....

does anyone know how to go around this?

cos i only want to have this as a gambling pc with no antivirus and all of this (lack of preformence 🙂 )

in regards