Showing results for 
Search instead for 
Did you mean: 

Intel 320 SSD 'write protected'?

Esteemed Contributor III

I have just bought an Intel 320 80GB SSD for use in a Windows 7 computer that I've put together myself. I have Windows 7 Enterprise installed and have installed the SSD Toolbox from the Intel site.

The toolbox application shows the drive to be 'security frozen'. I cannot make a partition in Computer Management nor do any secure erase operation.

I've tried powering the computer off for a number of minutes and then booting up. Sometime the drive doesn't even show up at all.

I have 2 Kingston SSDs and one OCZ SSD that I've had in use for many months under different Linux distributions. The OCZ for over a year. I'm disappointed that Intel, which I thought to be a good brand, is so poor and cannot be used out of the box.

I've been building PCs for over 15 years but I'm at a loss to know what to do with this drive. Every other hard drive I have bought both at home and at work has just 'worked'. Not so for Intel SSDs it seems.



Esteemed Contributor III

I performed the steps as outlined in this Wiki (from the parted magic command line)

and managed to issue a 'SECURITY ERASE' command, which appeared to clear the drive. However..

Still the same thing as before when Windows boots up, it reports 'media is write protected' when I try and make a partition table in Computer Management.

Ugh.. it's like we're back to keying in Cylinders, Heads and Sectors in our BIOSes to get drives to work (yes, I'm that old)

Too much hassle for a supposedly next generation storage device for sure.