Showing results for 
Search instead for 
Did you mean: 

Help! X25-M 80G is changed to intel bootloader

Esteemed Contributor III

Today I added a new WD HDD 640G, and one out of my 2 intel x25-m 80G did not work,,,

I checked and found that the driver of this ssd was changed to "intelBootloader", while another good ssd was called "INTEL SSDSA2M080G2GC"...

Could someone help me out of this problem, thanks!


CPU intel i7-920 oc 3.6G

Memory: OCZ 2G*2 1800MHz

Mainboard: Gigabyte EX58 UD5

Graphic card: Nivida GTX 260+

PSU: OCZ Z-1000W

Intel ICH10R SATA AHCI Controller


Esteemed Contributor III

Have you tried going into the drive properties and "updating" the driver?

Use the option to "search your computer to find a driver" and you should come up with a list that includeds the Intel driver.

If that doesn't work, you should be able to download the driver from Intel.

Esteemed Contributor III

Thanks for reply, i updated my driver of ssd which was downloaded from gigabyte website, the rst vesion is

another ssd which is working well has updated, but this one still displayed as intel bootloader, and only 6 MB volume...

I tried to bulid a new patition from this ssd (I have give up to restore the information from this disk...), and I could only get a patition of 6 MB...

what should i do, help!

Esteemed Contributor III

Now the ssd is only 8 MB volume and no date on!