Showing results for 
Search instead for 
Did you mean: 

Firmware Update Tool V1.7 ISO file

Esteemed Contributor III

Hello, I'm a new user of X25-M 80GB SSD drive.

Today I got a V1.7 ISO file, 011102M388208850.ISO and burned it on a CD-ROM media. After changing SATA to IDE mode, I did a cold boot of my PC. But error messages are shown.

Loading Operating System ...Boot from CD/DVD :1. FD 2.88MB System Type-(13)FreeDOS kernel build 2036 cvs [version Aug 18 2006 compiled Aug 18 2006]Kernel compatibility 7.10 - WATCOMC - 80386 CPU required - FAT32 support(C) Copyright 1995-2006 Pasquale J. Villani and The FreeDOS Project.All Rights Reserved. This is free software and comes with ABSOLUTELY NOWARRANTY; you can redistribute it and/or modify it under the terms of theeither version 2, or (at your option) any later version.- InitDiskBad or missing Command Interpreter: /P /E:256Enter the full shell command line:

Is this ISO file corrupted? I tried some times (inc. IE cache clear), all are same.

My PC has a H55 express chipset and Windows 7 works fine on this SSD.

ISO file size was 3,942,400 bytes.

Regards, YKJ

Esteemed Contributor III

I can't help on that error message, but assuming you have correctly imaged the firmware do you have a BIOS option for Compatible and Enhanced in the IDE mode settings? If so try Compatible. If that does not work try to update from a different PC if you can. It's worth the update


if you have a dos bootable usb flash drive, you can extract issdfut.exe from the iso (7-zip can do this), put it on the flash drive, boot from it, and update it that way.

Esteemed Contributor III

For some weird reason I was not able to do that with this f/w version. Previously it has worked, but this time I got a "not enough memory" message. Maybe just a quirk on my mobo. The CD image worked no problem.

was it a clean dos boot? it worked for me.