Showing results for 
Search instead for 
Did you mean: 

firmware update tool v1.7 hangs during scan

Esteemed Contributor III


I'm trying to upgrade the firmware on an X25-M 160GB SSD that I installed in a Thinkpad W510.

I created a bootable CD with v1.7 of the update tool.

The update tool boots and gets to the message:

"Scanning system for Intel SSDs ..."

It has been stuck there for 45 minutes so far.

I set the SATA mode to "Compatibility" as directed by the instructions. There is no "IDE" SATA mode option.

Any thoughts on whats wrong?




Esteemed Contributor III

I believe Compatibility is IDE mode. The scan should not take more than a few seconds.

Have you tried updating your BIOS?

Otherwise, do you have another computer avaliable to flash the drive?

Esteemed Contributor III

My BIOS is up-to-date.

I don't have another computer available.

Esteemed Contributor III

I too have the same problem. I have upgraded my W510 to the latest BIOS. Tried to set the SATA settings in both AHCI and Compability mode. The computer just stands there doing nothing during the scan. And no, I don't have any other computer to use as a host for it.

Esteemed Contributor III

After some thinking I came up with another idea. Perhaps it's all the CPU features in the BIOS that aremaking the updater hang. So I just disabled everything in the CPU-part of the config. Multicore, VT-d, Virtualization, all of it. Then I set the SATA mode to Compability mode.

Now the Updater found my SSD Disk in just seconds and I had no problems updating it.

Just remember to switch back the settings you changed in BIOS before you start Windows again as otherwise you might get some of thos enasty Blue Screens.