Showing results for 
Search instead for 
Did you mean: 

Firmware flash interrupted, how to force reflash procedure?

Esteemed Contributor III

Wanted to update the firmware of a X25-M 80GB drive. Right after the final yes/no question, the update process started but after a while was interrupted with following error message (no other messages in between):

"Error reading from drive A: DOS area: general failure""(A)bort, (R)etry, (I)gnore, (F)ail? _"

I tried "retry" with the same and a freshly written CD but couldn't continue after that point. I reckon the CD was in some part unreadable, but now I have a partially(?) updated firmware on the drive.

After rebooting the drive is recognised but I don't trust it at all (luckily there was no data on it). I tried reflashing with the freshly written CD but iSSDFUT.exe says the drive is already on the most recent version and doesn't want to reflash.

Is there a way to force the flash process anyway? Any switches/shortcuts? Or a different tool? Cannot find anything.




Hello, I would like to let you know that you can try again the firmware update, if the tool says that cannot recognize the Solid State Drive could be that the firmware update was done already, you can check this by open in Windows* (if the Solid State Drive works properly) the device manager and do a right click where says disk drives, right click at the Solid State Drive, properties and then at the last tab where says details at the property dropdown you select hardware Ids, if you have the latest version it should show: 2CV10HD.

In case that the SSD is not working anymore please contact us at the following phone number: 316 377 7000 option 6 so we can help you with an SSD replacement if that is the case.