Showing results for 
Search instead for 
Did you mean: 

80 GB (G2) not updating to 2CV102HD

Esteemed Contributor III

I need some help here...

I'm using the CD-ROM with the downloaded ISO file (110902HD88208850.iso). I run the firmware update with SATA in compatible mode.

Answered 'Yes' for all the questions. Update completes sucessfully displaying old version is 2CV102G9 and new vesion is 2CV102HD.

Re-run the update to verify everything is OK. Now the result for the rescan displays version 2CV102G9 (previous one).

As the SSD is new (out of the box) I decided to instal Windows 7 (64 bits) and take a look at what CrystaDiskInfo would report.

Installed Windows 7 (using AHCI mode) with no problems.

Installed CrystalDiskInfo and it reports 2CV102G9 for the SSD firmware version.

Repeated the firmware update several times to no avail.

<span style="font-family: 'Neo Sans Intel','sans-serif'; color: black; font-size: 10pt; mso-fareast-font-family: 'MS Mincho'; mso-bidi-font-family: 'Times New Roman'; mso-ansi-language: EN-US; ...


Esteemed Contributor III


I still got no ideas for updating my SSD correctly. As I said before, the update process seems to go well, but in the end it does not put in the new firmware.

Possibly (but doubtfully), the correct firmware is on the SSD and is just reported as being the old one.

How can I verify that TRIM is really being used?

Looking at al the discussions in this forum, I can't find anyone who has the same issue as I have....

Any clues?

I appreciate any thoughts on this.


New Contributor III
New Contributor III

Hi Iasp, Yes, it is the first case i see this updater behavior. I suggest you burn another CD-R with the update iso file (downloading it again, instead of using the one you possibly have already downloaded) and mark the option of the burner verify the copy after it made the copy. I have used the W7 built-in burner with good results. regards

Esteemed Contributor III

I was having issues updating my X25-M G2 (albeit slightly different, the update iso didnt see my drive) but i found this guide and it worked like a charm!


I hope this helps!

Esteemed Contributor III

Hi valdir and btmedic04 for your replies.

I downloaded another update and used the hint to use the USB instead.

It now worked fine.

Thank you guys...