Showing results for 
Search instead for 
Did you mean: 

670p Windows 10 SOLVED

New Contributor

Hello! I desperately need windows 10 to work on this laptop as it is a requirement for software i have purchased. 

Laptop is Asus Vivobook X1502Z using Intel 670p ssdpeknu 512gb

I searched the intel site for 670p drivers, but i ended up here.

I read the user guide

Page 10 - 4.2 Software Limitations

The following Windows version are validated by SolidigmTM Storage Driver:
Windows 11 ver. 21H2
Windows PE

So basically, this driver won't work with windows 10. 

But I am an optimist, so i downloaded

I found /Installer/

under that i found


Looked at the .inf file, and the PCI ID matches 8086:f1aa as found by linux

I went to load these drivers, and i had to uncheck "hide non compatible"

The drivers show up, but do not work!

I went into the UEFI settings, i do not see an AHCI option for the drive.  It shows up as Intel RST.

Googled intel rst driver - found this

Downloaded both the VMD and Non VMD zip files

Put them on the USB, tried the different driver packs, and PRESTO it works for me.

The secret seems to be extracting .cat / .inf / .sys files from each zip into their own folders, no more than one folder deep from the usb drive - or they won't be detected.

Also, using the windows media creator tool to make USB seems to help better than using a dd copy of the DVD.

anyway, windows 10 is NOW WORKING with the 670p.




Hello jimjam,

I hope you are having a great day.

We really appreciate the feedback and the workaround you have shared with the community as a resolution for this issue. Hopefully, it will be of great help to other users.

Remember that you can always contact us via the Solidigm Support Hub.

Best regards,

Solidigm Customer Support.