Showing results for 
Search instead for 
Did you mean: 

540 Fails Full Diagnostic Read Scan

New Contributor


My 540 fails the Full Diagnostic scan. I started having application hanging issues the other day and after ruling everything else out, I ran the Full Diagnostic Scan a couple of times from the Toolbox and it hangs anywhere from 0% to 15%. The Drive passes the Quick Diagnostic scan, passes the Data Integrity scan and has the latest firmware on it, version LSF041C. I've read multiple other posts online with the same issue with the same model drive.

When I ran chkdsk after the first Full Diagnostic scan, it found corruption and had to fix a bunch of security descriptors. However, this corruption may not be related to this read issue because I never performed chkdsk after this disk was cloned. After running chkdsk fixed the drive, I chkdsk'd it again to verify and it passed without any issues.

I've attached my SMART details. Everything looks fine. As per a previous post, I deleted the old IntelSSDTDK.log and re-ran the Full Diagnostic until it failed again. The resulting IntelSSDTDK.log file for the single scan is 2.3GB! It's attached. That also may be a bug to be reported in the Toolbox to the developers, that it wouldn't generate a new log file until the old one from April was manually deleted. ie it wouldn't write over the top of an existing log file.

Deleting the full drive and erasing with Secure Erase is out of the question and the problem is not related to anything exterior to the drive (cable, power, SATA port, etc...).

I see that the Toolbox has been on version 3.5.2 since March sometime. Is there a firmware update in the future which solves this issue since numerous other people have brought this problem to Intel's attention?

EDIT: The drive is also failing the backup process in the latest version of Acronis. It hits two bad blocks, one at a time and hangs indefinitely. If I hit the 'Ignore' button, Acronis will skip them and successfully back up the drive. This seems to show that it's a firmware issue because it's not marking these as bad blocks and handling them correctly.

I purchased this and another identical one 1-1/2 years ago through the Intel employee purchase program..



Esteemed Contributor III

Hello xrwright,

Thank you for your interest in the Intel® SSD 540s Series. You mention that your SSD has firmware version LSF041C. According to the Intel® Solid State Drive Toolbox – Release Notes ( the latest firmware version for your drive is LSF042C. Could you please update your SSD to the latest firmware and try to run the diagnostic again? I'll be waiting for your response. Regards,Andres V.

New Contributor

Hi Andres,

Sorry for the oversight on my part. I've updated to firmware 42C now.

Updated firmware, rebooted, ran chkdsk, rebooted and re-ran the Toolbox. Same result.

It hung at 7% with the same read error as before during the Full Diagnostic scan. The SMART details and the log are attached.


Esteemed Contributor III

Hello Robert,

Thank you for performing the firmware update. Since the issue persists after the suggested firmware update, and you mentioned that running a secure erase (and reinstalling the operating system) is not an option, please consider contacting your local support for further assistance and to find more about the available warranty options. Regards,Andres V.