Showing results for 
Search instead for 
Did you mean: 

To Update Firmware or NOT

Esteemed Contributor III


I started another thread here about my new X25-M that worked fine until I tried to update the firmware with the latest on Intel's site. For some reason, the update never completed sucessfully. The utility kept telling me to disable the drive password [there isn't one], enable SMART [the BIOS does not have it] or enable Legacy Mode [it was, in IDE mode]. I tried several times with a bootable USB drive and a CDR with the ISO image. I gave up after 3 or 4 attempts, only to find that my 80G drive was now an 8Meg drive.

From searching the net, I discovered that this had happended to others. Sometimes they were able to correct it by using HDDErase or DBan. I was not able to sucessfully run either of this. HDDErase ran but did not even see the SSD. Dban I never figured out. I downloaded and unzipped. I never found any system boot files or exe files to run on the disk it made.

So, back to the vendor it goes. A replacement is on the way. My question is, when it gets here, should I even attempt to update the firmware? I am a littel gun shy after this incident. Also, it there a way I can see what version it shipped with? Perhaps with Toolbox?



Esteemed Contributor III

Shipping FW is listed on the drive itself, near the intel logo. It will probably come with the latest anyway.

What motherboard have you got?

Esteemed Contributor III

MOBO - EVGA 141-BL-E760.

I looked on the SSD - it says FW: 02HA. Latest on Intel site is 02HD so I don't have the latest. Is 02HA OK or am I going to have decreased performance? The replacement SSD will be here today [out for delivery]. I will check the sticker - thanks for that info. If its not 02HD, should I try to update it or not? Totally my responsibility of course.....

Thanks !

Esteemed Contributor III

Personally, I would update, but you might be lucky and get one that has 02HD already.

Is it Intel RMA or from a shop?

Regarding your board, good, it has ICH10R controller.

If your replacement comes with a previous version you decide to upgrade, I would:

- make sure you disconnect all other HDDs except SSD.

- make sure the SATA port you connect to is controlled by ICH10R

- in your BIOS, set SATA MODE (IDE) like you've already done, and LEGACY Mode Support (Enabled).

PS. your original problem sounded like the HPA (host protected area) of the drive had been modified. This isn't an uncommon thing, as it can be used to make drives appear smaller than they are, and for OEMs to reserve space on drives. From memory, Seatools (seagate) for DOS has the ability to reset the HPA. Basically, your old drive was probably fine, but during some process where the HPA may have been modified, and eventually got stuck, it made your drive appear 8MB in size.

Esteemed Contributor III

The new SSD arrived with 02HD on it. I started to install Win7 on it. Right when it got to the part where you tell it where to install [the SSD was not formatted yet], the computert shut down. I restarted and now I keep getting a message telling me the BOOTMRG is missing and to hit CNTRL ALT DELETE to restart. Tried that - same thing.

I removed the Win 7 DVD and connected an external SATA drive that I have already installed Win 7 on. Disconnected the SSD also. Same message. So, NOW I think I have a MOBO issue. Any ideas ?

Back to the EVGA forum I guess. What next !!@@!